Jump to content

Dell Precision 690 - Cable Disconnected - Any network card detected


6 posts in this topic

Recommended Posts

I've got a vanilla install + AppleHDAPatcher + NVInject, sound and video are rock solid. On the network side, any card that I can get detected always shows the cable disconnected. I've got link lights, but OS X always shows disconnected. I'm currently focusing on an Intel PRO/1000 MT that is detected, dmesg shows 'AppleIntel8254XEthernet: Ethernet address <correct MAC>' switch has link light, but no luck.


I've tried using Chun-nan's patched IOPCIFamily.kext, but this made no difference. My Device string 'PCI\VEN_8086&DEV_1026&SUBSYS_10028086&REV_04\5&292877C9&0&300310' from Windows. Changed the IPCIPrimaryMatch string in /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleIntel8254XEthernet.kext/Contents/Info.plist from '0x10008086&0x0000ffff' to '0x10008086&0x0000ffff 0x10268086'


I also tried installing the SmallTree drivers, but that made no difference either.



Any ideas?


System in question is:

Dell Precision 690

Intel 5000X chipset (I think)

2GB Ram

nVidia 7800GT PCIExpress

Booting to External USB drive

Sigmatel 9200

Intel PRO/1000 MT Server Adapter

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Well, I have everything working! And at the end of the day, I did it with a retail DVD and the only changes necessary were adding dsmos.kext, removing AppleIntelCPUManagement.kext, installing nvinject 4.1 and running AppleHDAPatcher 1.2 with a dump for Sigmatel 9200, and replacing the AppleIntel8254XEthernet.kext in IONetworkingFamily.kext(for my Intel Pro 1000 MT.


dsmos.kext and AppleIntel8254XEthernet.kext I used were from Leo4All. I don't think dsmos.kext was any different from what was at the n00b guide.


I installed using my Macbook Pro, hooking up this drive as an external drive. I realize this isn't an option for many, but it was the simplest way for me. I was more focused on finding out what the minimal amount of modification from a vanilla retail install. I know this isn't a detailed guide, it's just a rough record of steps. Any commandline commands assume you are in the terminal and have cd'd to the correct directory(/System/Library for extensions.mkext and /System/Library/Extensions for everything else) I didn't include paths because if you are doing this as a parallel install the paths will all be goofy anyway.




Install EFI patch following step 2 of n00b guide (http://forum.insanelymac.com/index.php?showtopic=86167&hl=retail)


Install using OSInstall.mpkg(step 3 of n00b guide)


Copy dsmos.kext to the extensions folder and remove AppleIntelCPUManagement.kext, run 'sudo chown -R root:wheel dsmos.kext' 'sudo rm -R extensions.mkext'


That's all it took to get booted to a base working config. I ran software update and 10.5.2 crashed halfway through, so I had to reapply the update from a different install. After 10.5.2 I had to remove AppleIntelCPUManagement.kext again, otherwise no problems.


To get everything else working, install nvinject, run AppleHDAPatcher and copy AppleIntel8254XEthernet.kext into /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/ , run 'sudo chown -R root:wheel IONetworkingFamily.kext'


So Dell Precision 690 works(basic) with Retail DVD + EFI v8 + dsmos.kext - AppleIntelCPUManagement.kext, and complete with + nvinject4.1 + AppleHDAPatcher(Sigmatel9200) + IONetworkingFamily.kext(Leo4All)


On a side note, I have a Intel Pro 1000 MT Desktop adapter that causes all sorts of trouble, made the system totally unstable. The adapter that is working is the Intel Pro 1000 MT Server adapter. The desktop adapter is a standard PCI card while the Server adapter is a 64-bit PCI card.


All in all I have to say installing using OSInstall.mkpg from another install is the easiest way to go. That way you are starting with a clean vanilla retail install and only modify that which is necessary.

Link to comment
Share on other sites

The last note on this install, and the answer to the original problem of the post, is a weird one. I originally was trying to get 2 cards working, the Intel Pro/1000 MT Server adapter and the Intel Pro/1000 MT Desktop adapter. Originally both were recognized but showed disconnected state regardless of whether a cable was there or not. I have it working with the Leo4All IONetworkingFamily.kext, but . . . only if both cards are installed in 64-bit PCI slots, even though one of them is a 32-bit PCI card. Here's what I tried:


Precision 690 has 3 slots, 2 x 64-bit and 1 x 32-bit. I used 3 cards, an older Intel Pro/100 (32-bit), the Pro/1000 Desktop(32-bit) and the Pro/1000 Server(64-bit)


Pro/1000 Desktop + Pro/1000 Server, both installed in 64-bit slots works, doesn't matter which one goes in which slot

Pro/1000 Desktop + Pro/1000 Server, Pro/1000 Desktop in 32-bit slot - doesn't work

Pro/1000 Server + Pro/100, both installed in 64-bit slots - doesn't work

Pro/1000 Server + Pro/100, Pro/100 installed in 32-bit slot - doesn't work


So the Pro/1000 Server adapter and the Pro/1000 Desktop adapter both appear to require both 64-bit slots to be full, but they can't be filled with just any card. And in the end the Pro/1000 Desktop was flakey(caused many kernel panics), so I left it installed and just deactivated it.

Link to comment
Share on other sites

  • 2 years later...

  • Create New...