Jump to content

Disk Utility can't erase fat32 and make journaled format


3 posts in this topic

Recommended Posts

Here are my computer specs:


-Sager 2090

-Intel Core 2 Duo 2.2 Ghz

-160 GB SATA hard drive

-4gb RAM


My hard drive is partitioned like this:


-Primary 20 GB NTFS Windows XP

-Primary 40 GB FAT32 for OSX Leopard

-Extended 100 GB NTFS for other applications


I booted off of the Kalyway disk. If I try to format the 40 GB FAT32 as MAC OS (Journaled) with Disk Utility, it erases but then still reports the volume as being formatted in FAT32. If I try to "Erase Free Space" it gives me an error that it "could not create temporary file". After "erasing" the disk will turn grey and unmount. The only way to mount is and make it black is to erase again as MS-DOS (FAT) format. I can't erase it with MAC OS (Journaled) for some reason.


I've tried making the partition unformated, NTFS, FAT32, and moving the osx partition to different parts of the drive. No matter what, the Disk Utility won't erase and make the partition HFS+ / MAC OS (Journaled). I've tried using Partition Magic, Acronis, Gparted. Nothing helps.


Is there something special I need to do? Is there another program I can use to format the partition as the right format so I can just load the dvd and install (avoiding Disk Utility entirely)?


Thank you for any thoughts.

Link to comment
Share on other sites


  • Create New...