Jump to content

Olitec wifi pccard RT2500 based works on 10.5.1


2 posts in this topic

Recommended Posts



Yesterday I succesfully got my TI PCIxx12 Cardbus bridge working with Chun-Nan driver.


So when I insert my Olitec WiFi RT2500 based pccard the system now find it.

I use Kalyway 10.5.1 with vanilla kernel.


Today, after searching the forum I just went to Ralink site:


and download the driver for RT61 and RT2500.

I was afraid it doesn't work because it's for Tiger 10.3 & 10.4 and thought may be some librairy or binary will no match.


However to my great satisfaction it works directly out of the package.

There are 2 packets: 10.3 & 10.4 = I choosed 10.4 install it, reboot and it works directly!


Before installing I disable my router wep encryption (I prefer to start with simple things)

My router is DHCP server

After reboot I checked with ifconfig = en0 exists and got an IP adress, good!

I tried a ping somewhere on the internet : also works!

launch a browser: works! good good!


However I confirm (as said by Greenturtle985) the system see the card as an ethernet card (en0). Airport Utility doesn't see it; but the Ralink utilities supplied in the package is smart enought to configure the card.

After enabling back the router wep encryption, and the wep key entered in the Ralink Utilities it's OK again. However I confirm (as mentioned by cambios) that key must be lower case only! Strange because I know this Ralink utilities and used it in Windows & Linux; it's the same interface; and on those systems there is no this lowercase limitation! Strange!..

I also have a D-Link DWL-G630 wifi card, it's RT61 based. Even if the driver is supposed to work for both chipset, RT2500 & RT61 I confirm (as said by Macgirl : it's PPC only) it's not working on my computer.


I even got Apple's software updates, but I didn't update the system to 10.5.2 as proposed, I'm afraid to do it even if read I can do it with vanilla kernel system. I will do it later (after backup).


My computer is laptop Acer Aspire 3680 (note the onboard atheros wifi card is not installed because bought in Russia, that's why I use a wifi pccard)

I run Kalyway 10.5.1 with vanilla kernel.


May be this can help others...

I will also update the wiki hcl




Link to comment
Share on other sites

I have been trying to download this:




But I get the error "codec overrun" every time I try to mount it. I am using iATKOS v1.0i btw. I have the Buffalo keychain USB based on the RT2500 chipset. Can anyone try to download this and mount it. I get the "codec overrun" no matter which computers or browsers I used.


If it works for you, can you please ZIP it up and attach it to the post.

Link to comment
Share on other sites


  • Create New...