Jump to content

Gateway C-140x notebook keyboard setup


5 posts in this topic

Recommended Posts

So a few weeks I started reading as much as I could about osx86 and getting Leopard working on non-apple hardware. I decided to go for it about 1.5 weeks ago and was somewhat sucessful. I am running Kalaway 10.5.1 with the vanila kernel and the two fixes (ACPIPlatform and ps2 support) installed under customize.


The biggest problem I have right now is that my internal keyboard does not function.


I have tried:


1. Kextload/unload

2. Repairing permissions

3. Various AppleACPIPS2Nub.kexts

4. Moving around the above kext to Extensions as well as the AppleACPIPlatform.kext plugins directory

5. Reinstalling

6. Enabling/Disabling legacy support for USB

7. New AppleACPIPlatform.kext

8. New ApplePS2Controller.kext


My specs for the internal keyboard are as follows:

Keyboard: Keyboard matrix connected to KBC via motherboard

Hardware IDs: ACPI\PNP0303

Service i8042prt


Let me know if any other information would be useful.


The other issues are ones which are being worked on (8256x wired, 3945 wireless, etc) and don't really have any questions about these other things.


I also have the Ati 2300 HD, anyone know if it would work with the drivers for the 2600HD? I am pretty sure the 2300x is a completely different architecture, correct me if I am wrong.


Thanks so much in advance for the suggestions. I really don't want to have to abandon this project, but a laptop is pretty useful without a keyboard.

Link to comment
Share on other sites

  • 3 weeks later...

Anyone have any things to try? Without the internal keyboard, OSX is kind of useless.


Does anyone think that downgrading to 10.4.x would help? I am just eager to get osx working with my keyboard and don't have much preference on version.

Link to comment
Share on other sites

  • 6 months later...

  • Create New...