Jump to content

No Hard Drives Detected - Kalyway 10.5.1


7 posts in this topic

Recommended Posts



When I try to install Kalyway 10.5.1 on my home built desktop, I get all the way in the install process where I'm asked to "Select Destination - Where do you want to install Leopard" screen. And there are no hard drives listed.

I then go to Disk Utility and it only detects my DVD-CD/RW drive and my DVD/RW drive and nothing else.

So far I've set up a 50 GB partion on my SATA Raid set for the OS X install. I set it to Primary/Active but didn't format it.

I also have set up a 80GB IDE drive as Primary/Active and formatted it as FAT32. It's the master drive on the IDE cable but in order for my windows to detect them I have to set the jumpers to cable select. There is also 20GB HD on the slave part of the IDE cable formatted NTFS also set to cable select.

But none of my HDD drives are visible.

Some posts I've read state that there might be problems with SATA drives in a RAID but other posts people said that RAID worked for them. But I haven't seen anyone post anything about Intel Matrix RAID set ups. Anyway my IDE drive should be detected.

What's up with this?



Link to comment
Share on other sites



Is there anybody there?


Where are all the experts?


I see other people replying to other peoples similar posts, but nobody replies to my posts.


Have I been blacklisted or something?

Link to comment
Share on other sites

  • 1 year later...

Hello All,

I have a very similar problem and thought I would add one thing I tried although unsuccessfully. I once ran into a problem in the PC world with a SATA drive. It seems that Windows XP did not have a SATA controller as part of the OS. I was instructed to change (in the BIOS) the Hard Drive type to IDE rather than SATA. It worked in that instance, but, alas, not this time.

I am trying to load Kalyway 10.5.2 to a Intel D945GCLF2 motherboard. The HCL on OSx86 states that it loads and works with no patches or tweaks. The boot starts normally (I think) and gets into the installation GUI but when it gets to the screen where you are to choose a disk to install OS X to it is blank. I went into the BIOS and changed the disk type from 'Native' to 'Legacy' but it did not work.

One item that is of interest is that when I first tried the installation, there was an OS on the HD. The installer recognized the disk at that time but would not let me load to it because it stated that 'The contents could not be changed'. So, I got out of the install and wrote zeroes to the entire disk and tried again and the disk now is not recognized at all.

Any assistance anyone might provide would be appreciated. Thanks

Link to comment
Share on other sites

Hello again, a brief helping hand. I reasoned that since I had erased the hard drive completely, the installer might not be recognizing it at all. TRUE! So, I went back and partitioned the HD, formatted the partition, and tried installing again. This time the install recognized the disk but stated that I couldn't install OS X because the contents could not be changed. I did a bit of research and found that you can go back a screen or two and go into 'Utilities' and 'Disk Utility' and tinker with the disk until you get in a mode that the installer likes. I did this and now I am proceeding with the install. Hope this helps.

Link to comment
Share on other sites

Grab a different copy. Leo4all has the SATA drivers you're after. Once installed, you'll need to boot back to the installation disk, open terminal, and input the following commands:


Change Leo4Allv3 to whatever your install DVD's volume name is, and MacHD to whatever your install HD is; do this for all steps


cp -pr /Volumes/Leo4allv3/System/Library/Extensions/*ATA* /Volumes/MacHD/System/Library/Extensions/.



chown -R root:wheel /Volumes/MacHD/System/Library/Extensions/*ATA*

chmod -R 755 /Volumes/MacHD/System/Library/Extensions/*ATA*



rm -rf /Volumes/MacHD/System/Library/Extensions.*



You may now restart your computer. I would suggest pressing F8 while booting and then entering -f as a boot option to force reloading of the kexts.

Link to comment
Share on other sites


  • Create New...