Jump to content

Difficulty getting SATA working - Mac OS X 10.4.8 [JaS AMD-Intel-SSE2-SSE3 with PPF1 & PPF2]


3 posts in this topic

Recommended Posts

O.K, so first of all my notebooks hardware specification :


Mainboard: Quanta Note-Book motherboard (nForce 630M) nforce5?

CPU: AMD Turion Dual-Core 1900mhz 64bit

Memory: 2GB DDR2 @ 667mhz

DVDR/W / RAM drive: ATA ATAPI Optiarc DVD RW

Hard-Disk: Seagate Momentus AHCI 5400.3 SATA 160GB

Audio Card: Conexant HD Audio

GPU: Nvidia 7150M


The problem is that my specific distribution of osX - Mac OS X 10.4.8 [JaS AMD-Intel-SSE2-SSE3 with PPF1 & PPF2]

has difficulty reading my SATA hard-disk.


Now I have read up a lot on the problems with this and so as a result I have tried many different methods to get my specific SATA controller working within osX. The installer disk-utility detects my DVD drive just fine but can't see my harddisk.


At first I thought that if I tried injecting the approriate nforce kext files, or perhaps modifying the stock AppleVIAATA.kext with my device id's (in this case 0x055010de & 0x056010de) into the Tiger image that I'd be able to get the installer to at least acknowledge the existance of my harddisk drive. Unfortunately neither worked.


I had a look at meDevils nForce drivers; and realised that they didn't support AHCI based SATA hard-disks on my chipset. I've read in various places that by disabling AHCI in the bios and setting it to IDE emulation that I'd be able to get the installer to recognise my harddisk. Here the problem lies that my specific notebook bios (Phoenix Bios) is extremely restricted and doesn't offer such an option as a choice ... figures.


I did however manage to install osX to my harddisk by using vmware to install osX to a virtual harddisk, and then I converted that image into a raw file and injected the contents of that image onto a seperate partition of type "af". (I will probably write a tutorial on how to do this later)


I have managed to successfully install osX to my harddisk and I can boot to it successfully using chain0 upon booting my p.c, however as was the problem with the installer I cannot get it to "see" my SATA harddisk drive and I get a "root device not found" error upon booting; presumably it can't find my sata harddisk and this is what this error refers to?


I do have access to osX and it's terminal commands etc, as I can boot succesfully and use osX successfully from within vmWare (this is how I was able to sort out permissions and ownership during injecting kexts into the install image).


Anyway I realise that it may not be possible with an nforce5 chipset to get osX running, but any suggestions (other than using a USB harddisk) would be appreciated! Perhaps someone knows of a way of accessing advanced settings within Phoenix bios?

Link to comment
Share on other sites


  • Create New...