Jump to content

Sudo problem


3 posts in this topic

Recommended Posts

Hey everyone, I just installed OSX 10.5 on my AMD 64 X2 and it went pretty well. The sound works, my mouse works and the operating system actually functions. When I created my account I set a password, lets just call it "w3sawe". Since my keyboard is not a USB keyboard but a PS/2 one, I had to install one of the things I got from this forum, I think it was ApplePS2Controller.kext. Anyway, to install this I guess I needed to run commands as the root user so su [command]. When I ran this I got the following prompt:


which I then typed in (w2sawe) without the cursor moving (I guess that happens, it happens in Ubuntu too). Oh just to clarify I'm using a USB keyboard to do this but its not a permanent solution. After I press enter all it says is something like "su: Sorry". I then got rid of my password and tried it and it still did not work. I am running Windows on another hard drive since I cannot install keyboard support or my LAN driver without su working. Is there anything I can do to fix this problem?

Link to comment
Share on other sites

Hey I found this solution I think:

if you already enabled root account as i described, simply logout (click on the apple and choose logout).

If the login screen shows a list of users it won't show the "root" user so you will have to select "Other". Then in the username field type "root", under that type your root password, and voila - you're root.


And now, for the tricky part.

When logged in as root, open terminal and type


visudo -f /etc/sudoers


If you never worked with vi editor in unix, you'll be quite confused.

Maybe it would be smart to read info on visudo or vi editor.

You cannot edit the file until you enter "INSERT" mode (press "i"), and then edit the file as %admin ALL=(ALL) NOPASSWD: ALL. Then press Escape to exit "INSERT" mode, and type


:w! /etc/sudoers


- semicolon ":" is used to give commands to vi (or visudo) - after that you can give commands

- w stands for "write" command and an exclamation sign "!" stands for overwrite

when you see message "file written" or something like that, simply close terminal, logout, and login as regular user.

Now, after typing


sudo -s

in terminal you should be able to do root stuff.


hope this is not too complicated.


good luck!


The only problem is I need root privileges to edit etc/sudoers :'( Can someone help out with that?

Link to comment
Share on other sites


  • Create New...