Jump to content

Installation Report on Acer Aspire 5315 Laptop


3 posts in this topic

Recommended Posts

Installed from Jas 10.4.8 AMD/Intel DVD onto an external USB hard drive. Selected Azalea audio and Intel drivers from customization dialogue. Install went smoothly, then used tha Acer BIOS to set boot order (DVD drive first, USB drive second, internal hard drive third). External USB drive booted normally after install, but no ethernet, wireless or sound was available, and only one display resolution was available. Otherwise OS X ran very snappy.


Major fan operation bug - Ubuntu users discovered this:



Short version, the fan on this machine is controlled by software, not by the motherboard, and the software is windows-only, part of the Acer ePower Management suite that must be installed with Vista or XP. If the machine enters sleep or standby mode, the fan does not start up again when the machine wakes up. So after 20 or 30 minutes the machine shuts down due to thermal overload. Only a full restart will make it work again. (after a cooling-off period)


So as a hackintosh, this could be a deal-breaker. My 5315 dutifully shut down after about 30 minutes of running OS X. No fan running at all.


What do I do to get Wireless, sound, and Ethernet to work? (machine details below)


Machine: Acer Aspire 5315 (got it for $397 Canadian at Wal-Mart in December 2007)

Processor: Intel Celeron M 530, Conroe-L @ 1.73GHz

Instruction sets MMX, SSE, SSE2, SSE3, SSSE3, EM64T





Northbridge Intel GM965 rev. C0

Southbridge Intel 82801HBM (ICH8-ME) rev. 03

Memory Type DDR2

Memory Size 1024 MBytes

Memory Frequency 266.0 MHz (1:2)


Video: Mobile Intel® 965 Express Chipset Family

(only one resolution available, 1024x768, I assume this means no Quartz Extreme)


Built-in Ethernet: Broadcom NetLink Fast Ethernet 57XX series

(not recognized)


WiFi: Atheros AR5211

(not recognized)


Sound: Realtek HD Audio

(not working)


DVD Drive Recognized, did not test DVD Player.


Keyboard and trackpad working (including 4-way center rocker button)

(no way to disable tap-to-click though, grr)

Link to comment
Share on other sites

  • 4 months later...

have the same specs.

my audio is working, my display runs at 1280x800 and my WiFi: Atheros AR5211gets recognized, i just need to get my dammed Built-in Ethernet: Broadcom NetLink Fast Ethernet 57XX series to work, let me know if you find something .


here are the specs for it:

82801H(ICH8 Family) PCI Express Port3

Device:82801H (ICH8 Family) PCI Express Port


info.vendor:Intel Corporation



-info.vendor:Broadcom Corporation

-pci.product_id:5907 (0x1713)

-pci.subsys_product_id:310 (0x136)

-pci.subsys_vendor:Acer Incorporated [ALI]

-pci.subsys_vendor_id:4133 (0x1025)

-pci.vendor:Broadcom Corporation

-pci.vendor_id:5348 (0x14e4)

Link to comment
Share on other sites

  • 1 month later...

Aspire 5315


* Current OS X Version: 10.5.2


* Desktop/Laptop : Laptop


* Manufacturer: Acer

* Model: Aspire 5315 051G08Mi


* Install Methods summary:


Used Leo4All V3, Vanilla kernel 9.2.2 (I think thats the version number, i selected the most recent one). Got stuck during install at teh welcome screen, which kept looping over and over. Bypassed this by booting with -s switch and creating a root password. Everything else worked fine during install.


* BIOS Version: 1.43 (I flashed it from XP to patch the fan issues. Everything seems to be fine now)

* BIOS setup options: Sata set to AHCI Mode

* Processor Model: Intel Celeron

* Speed: 1.73GHz, 533 MHz FSB, 1MB L2 cache.

* Recognized as what in System Profiler: Intel Celeron CPU 530

* Audio: Realtek High Definition Audio (10EC:0268), works perfectly with ALC268FIX.zip

* LAN: Broadcom Netlink Fast Ethernet (14E4:1713), Not working, couldnt find driver.

* WLAN: Atheros AR5007EG Wireless Network Adapter (168C:001C), Not working, Not Supported.

* Modem: HDAudio Soft data fax Modem with smart cp (14F1:2C06), Untested as I dont need it.

* SATA & IDE: SATA worked out of the box. IDE untested.

* Partitoned as MBR drive (So I can duel boot with XP)

* Graphics: Mobile Intel 965 Express Chipset Family X3100 256MB (8086:2A02) Working perfectly by installing LeopardGraphicsUpdate1.0.dmg from the apple site.

* Quartz Extreme : Supported, all resolutions available.

* Other Accessories (USB/FIREWIRE) : Yes

* Name: Edimax EW-7318Ug USB Wireless Device

* Manufacturer: RaLink

* Works : Yes, Drivers available from manufacturers site work fine. Usb Wireless card gets detected as an Ethernet device, but works!



Youtube video :




I only had a few problems when installing this, all in all, only the network devices were not supported on my machine. This was overcome easily by using a usb device.


feel free comment on my page where this is journalled. I will answer questions there (i am more likely to check back there than to this thread.)







oh, btw...


when quartz extreme is working, this laptop will also allow VMWare Fusion!


I got Win XP running in Unity no problems, and works great!



Link to comment
Share on other sites


  • Create New...