Jump to content

x86 install of Leopard on a T2542 e-machine


5 posts in this topic

Recommended Posts

Hi Everyone,


I am an avid mac user, and EULA follower. Presently I have an irritating problem that others might enjoy the history of -- and an x86 install of Leopard that I would like some pointers on.


I bought an Ibook a couple of years back to attend college, and the logic board died -- so I bought a second one as backup while my first one was being repaired under warranty. After getting the original computer back, a little while later, the hard drive failed -- so I replaced it.

No major problems for about two years -- then my second iBook's hard drive died just before December 2007. So, I figure a new hard drive -- no problem.

Then I graduated and am trying to get work, when I happily found people who love custom mac programming. So I got started recently with my iBook with the new hard drive -- when lo and behold the logic board died on it too. Now on the backup computer the hard drive is dying again, and the logic board is going flaky again -- I have strung two customers out due to the apple failures (perpetual), and I think you get the picture about what I think about buying another mac right now --- (ps. i'm broke.). Thats more than 4 failures in three years -- Ick.


So, I have TWO legal apple logos from the laptop screens, (which still work), and one is now mounted on my old e-machine 2542 which used to run Linux.

(I bought the macs for Unix + Microsoft word for college -- but unfortunately, the work I do is on Macs. Gnustep doesn't quite cut it.)

Ps. I'm a BSEE with no money but some time right now... and some customers who would love to pay me for finished work....


Since I wish to obey the EULA, and if Apple sues -- :) DMCA reverse engineering is legal -- So I downloaded the BrazilMac patch and I own a single user copy of Leopard from Apple.


I have pulled the new hard drive from the primary dead Apple, and it still works. (No use pulling the dying hard drive from the other one...)

But I have no idea if it is useful, as it was a PPC not an x86 mac -- I don't own Tiger.


So, after patching a backup DVD with my original Leopard, and getting the SSE2 kernel -- since the 2.5Ghz celeron is SSE2, I tried to boot the DVD using my MadDog DVD burner out and putting it in the e-machine. Cool and Fast!


It boots. :) and much less than 15minutes to the install screen....


So, I am drooling a bit now -- But (of course) no joy.


Q#1: The DVD burned courtesy of my brother's Imac fails to verify on his machine -- no matter how many times I burn it, but other DVD iso images burn fine -- I see other posts on the internet which suggest this problem may not be my brother's hardware -- so does anyone know of Apple doing something to disk utility which could cause this, or am I experiencing a fluke? Or perhaps is it a bug in Panther? (I don't own Tiger, and I want to be legal).


Q#2 I am able to boot the DVD on my e-machine. I am able to F8 and go single user mode (-s), I am able to F8 and COMPLETELY boot using -x -v.

I am able to use disk utility to format my Seagate barracuda PATA/100 Ide drives. I can get to the terminal.

I have a working PS2 mouse and keyboard.

I can mount a USB memory stick, either 64Meg or 128Meg from the -x -v boot.


Now the bad stuff, worse, and really annoying --

If I try to boot the DVD straight, the apple screen comes up all pretty, the wait graphic spins, and then after several minutes it stops .... permanently.

So, I must boot using F8 -x -v, or -s .... no problem there.


When I boot F8 -x -v, it makes it all the way to the installation screen and rather than color, it comes up in dithered black and white which is hard to read -- but this isn't a surprise, for I have to manually tell X-Windows under Linux a wrong video driver or it will do the same thing.

Intel Xtreme graphics built in !!!! ( G version, vesa. -- yes I could rob my poor 200Mhz pentium of its PCI graphics card, but then I couldn't write to you!)

--- so that is just tweaking a kext, which I can do later, and maybe everyone will benefit....


However, my DVD WILL NOT install all of Leopard on the drive, but fails part way into the installation (missing files / DVD read error possibly).

From the normal install boot, the system will hang at the transition from the white apple screen with the wait rotator.


On the other hand F8 -x -v works correctly.

From that boot I can get to disk utilities, and to terminal (Yes at least one thing went right !)


If I single user boot F8 -s, it also comes up -- but apparently BrazilMac loads a ramdrive because when I do a "mount" at the command line none of the hard drives or the DVD are shown as the mount point for root. The automounter is not working, because plugging in usb memory does not mount -- nor can mount -uw / -- so my knowledge of hdiutil and friends is too limited to troubleshoot.


Also, I tried to mount my old mini-IDE drive from my laptop install as an external USB -- hoping to try copying it, but I get a USB bus error when I do so.

So, I am neatly trapped no matter what avenue I try -- but it ALMOST works.


Rebooting withoug the DVD just simply fails -- so the install was not complete enough to do what I would like.

I can boot and run linux, and do anything from low level copies to high -- but not on OS-X extended partitions...

My experience with hdiutils under osX is NOOB, and even though I have had some successs -- eg: eject, I am not able

to figure out what is wrong with trying to do something like: hdiutil attach /dev/disk1 or disk1s1 or rdisk1s1 etc...

It doesn't work from the F8 -s boot.


The last thing I tried in desperation was formatting the harddrive with OS-X extended journaled (the default),

going to the new mount point /Volumes/Leopard and using ditto /Volumes/OS\ X\ install\ x86 /Volumes/Leopard

It copied to the IDE barracuda but it won't boot. I even tried running the Brazil mac postinstall script using a USB memory

to supply the files -- but apparently it needs a true install of OS-X to work....


I mostly work from Bash in linux and OS-X, so I am very familiar with that and Gnu tools. You won't loose me talking normal unix.


What is the best attack plan to solve this problem.


#2a is there a way to boot the hard drive using F8 from the DVD so that I can insert new DVDs and try modifying kexts and the like until I solve it.

#2b is the USB bus error something that someone might know how to fix?

#2c In the debugging logs I notice that the RTL8xxx ethernet card is recognized, so would ethernet be useful alternatively.

#3a I have no firewire, but I do have the use of an Imac for a little while -- I also have a mad dog external DVD burner case which I think would take my barracuda IDE drives -- If that works, (I will be checking shortly), how would I install leopard to that without destroying my brother's IMac.


Thanks so much ... and I hope I am able to add to the knowledge base.

Link to comment
Share on other sites

To answer part of my own post, I discovered a solution to the DVD burner issue -- 16x rate DVD's are flaky, several of them Maxell, and others will not burn a full 4.3 Gb image from the iMac. So, I tried as a last resort buying some really cheap 1x, 2x DVD RW (Sony !), and those worked and verified correctly.


I don't know if it is a software issue or hardware, but as a clue to others getting bad DVD's over and over -- if all else fails, try buying a lower speed DVD. If your laser is a little bit weak, this will force it to spend more time making better marks -- and if it is a software issue, it seems to do the trick. :)


Before startup of the DVD, a single line read:

Vesa 3.0 (Brookdale-G chip accelerated VGA BIOS) 832KB.

This is interesting as another poster on this site trying to install on the same machine T8542 indicated that the Xtreme video has far more memory than that. 32M - 64M. It does appear to trigger the 4bit monochrome bug in OS-X, and there is no way in the BIOS to alter the memory allocated to the graphics card. I'll have to wrestle with that later, but this card definitely makes for ugly graphics.


The DVD will still not boot straight, but still requires the F8 -x -v or the F8 -s sequence.

Attempting to boot straight locks up as before....


I watched the startup log carefully this time, I am runing kernel 9.0.0

During startup com.apple.driver.AppleApicId complained about dual dependency on com.apple.kernel and com.apple.kpi -- which it didn't like having both styles .... Don't know what that is about, so if you do, I'd appreciate knowing what it is.


It did find the RTL8139 network chip (yes)


mDNSresponder is missing, so there is no surprise that errors happen on that -- which are probably normal.

CoreRaidSever failed, which is something I would like to get running -- the iBook can't do raid, and that was 50% of my earlier problems....


The only odd thing at all is that in /System/Libraries/StartupItems the boot failed to count the number of files.

Is that normal?


The boot recognized the PS2 mouse and keyboard again, but both of them timed out and didn't function this time -- I had to plug a usb mouse in. For some reason the boot seems random, the mouse & keyboard usually work -- but every once in a while they both fail. USB mice also work and fail, though the PC USB keyboard doesn't like to work very well..


I wonder where to look for the reason for that.... SImple reboot does not seem to do the trick, a power down seems to be required.... hmmm....


I ran the install from -x -v boot, and it got as far as checking media -- which of course I should have thought to cancel.

But even retrying with cancelling it comes back saying:


"The installer could not locate the are to install the software, check your install media or internet connection and try again or contact the software manufacturer for assistance."




My apple care is expired, that why I'm here at all...

and that is the same message I got with what I thought was a corrupted CD, and this time I am certain it isn't corrupted.


I have also noticed that once an install to the hard drive goes bad, getting any further does not happen without zeroing part of the IDE drive again.... so that is something to consider for those getting stuck. :)


More later as I get farther -- If you know how to solve any of this, I'd appreciate the help.

Link to comment
Share on other sites

Well, things are progressing. SInce others may have problems, and the answers aren't in one place -- I'll continue answering my own questions for the benefit of others....


I realized that the errror message I got during install was because the BrazilMac package removed certain packages from the install disk to make space for the hacks, and since the instructions were for a single layer DVD -- those packages *MUST* be deselcted using the customize button to work -- it is not optional to deselect the extra packages, one must do so.


On a e-machine system which one can't see clearly because of the B&W dither problem, the answer is that the customize button is on the left after the drive selection menu of the install. Uncheck ALL boxes, and the install will succeed at least most of the way. eg: mine went at least to the 2/3rds mark before it mysteriously rebooted -- I don't know if it was finished, or if something went wrong because it isn't obvious.


I also know now that DiskUtility which I used to format the IDE drive with UFS before the install probably didn't have the correct MBR setting to make the system bootable since I couldn't see well enough to set the options. Since the terminal screen is readable, I'll work from there and try to install the bootloader for UFS systems from the command line. HFS filesystem booting seems to be more of a problem, so I will just stick with UFS, and write a script later for others to use if they too get stuck with an unreadable screen.... :)


On the install DVD BrazilMac puts in the /usr/standalone/i386 directory: boot0, boot, boot1h, boot1u


These are the custom boot files to get around bootloader problems.

People using Grub or Lilo from Linux, etc. do not need boot0 which is the whole hard drive master boot record (MBR)loader.


Everyone needs two bootloader files, boot and one of boot1h (for HFS systems) or boot1u (for UFS systems).


Since I am not using multi-boot, but only OS-X, I will use boot0, boot1u, and boot.

The IDE HDD will boot from boot0 -> boot1u -> boot

Getting these three to link together requires using fdisk to set the bootable PARTITION (not the Leopard UFS filesystem but its master partiton), boot1u is smart enough to read a UFS partition table, and locate appropriate files on that partition (eg: from other threads I have read) but apparently a program called startupfiletool is required to link boot1u to the final "boot" program which launches OS-X.


So, the commands I have are fdisk, dd, and bless the one missing one is startupfiletool, and I need to make sure the copy I use is legal. I'll post a bash script once I get this to work as a cut and paste codebox so others who are stuck can work through the boot problem at least....

Link to comment
Share on other sites

Another update:


The UFS idea didn't work. Clearly x86 with Leopard will only boot from hfs. So, the other thread I read is out of date.

It can and DOES boot from HFS whether case insensitive or sensitive. eg: boot1h copied to the master file of the OS-X partition in some mysterious way...


I was able to get the system to boot from HDD once, but it will not repeat the experience.

After it booted, it took my dead laptop HDD which was attached during the setup screens and copied all information from it onto the system -- which makes me wonder if it copied some powerPC only files or something which wont work with the x86 version of Leopard. My Ibooks are both G4's not Intel.


There is a bug in the eXtreme graphics bios of the T2542 which has nothing to do with the capabilities of the system, or with Mac OS-X. (This is a universal bug affecting Linux, OS2, etc.etc.etc. so this information is generic.)


Oddly enough, when a VESA3 probe of the VESA extensions happens, only 256 color mode is available and about 845K of video ram which is way less than the maximum VESA mode of this card. As the 845GV/GE is capable of 64 Megs of shared memeory and there is no way to set this in the T2542 boot BIOS to select the amount available, I peeked around and discovered that if VESA2 extensions are queried by a manual boot program instead of VESA3 -- the system correctly identifies 32bit per pixel capability with up to 1280x1024 resolution. (YAY!). So, replacing the KEXTs or modifying OS-X ought to be unnecessary if I can figure out a way to force the VESA2 extensions to be reported during boot -- rather than the VESA3 extensions which trigger the OS-X B&W dithering bug on this system.


Now, when I boot -- the system goes through the normal loading of kexts from HDD but dies at the resolution switch where the system goes the last few steps before becoming a graphics login. After studying the issue a litte, I noticed that the BrazilMac patch automatically installed the boot.efi file rather than the standard boot file on the actual startup partition.

And I also notice some minor firmware issues showing up in the boot log == so I wonder if my version of BrazilMac is designed for the SSE3 kernel and EFI -- which is probably ruining the boot since I don't have EFI, and I must use an SSE2 kernel since this is a CELERON processor 2.5GHz -- Not an SSE3 capable processor. (I am almost tempted to buy one, but then -- I'm broke, thanks apple.)


If anyone else has had the trouble and knows where the problem truly lies, even if not the solution, I would sure apprecaiate it to save some time. It was really cool to see the system come up once!


I also noticed that one can place LILO (and I assume Grub) on the master boot partition instead of boot0, and then point it to "other" os, and the OS-X partition, and it WILL boot identical to the boot0 program, so the only things of importance during booting are boot1h (installed by dd in my case to the hfs partition) the boot OR boot.,efi program installed by BrazilMac, and the installation of Leopard. At least my apple logo is happily glowing -- but I sure would like to make this stable now that I have a taste of success! I am not sure what bless has to do with any of this, because it seems superfluous -- but maybe it does....

Link to comment
Share on other sites

  • 2 weeks later...

Mostly Working now!


I figured out the boot problem -- as I was using two hard drives, one to experiment and one to boot from -- the system was confusing the /dev/disk0s1 and /dev/disk1s1 occasionally, as the order seems to depend on the boot. So, I added a note in the base of each drive "This_IS_HDA" "THIS_IS_HDB" so I could tell which was which for certain regardless of whether I booted from DVD, HD, etc. (Renaming the BOOT partitions different names, and using the brain is good...)


Some problems arise when /System/Library/Extensions.mkext and Extensions.kextcache are deleted -- as is desirable if the system is ever to be stable on its own it should be able to boot with those caches deleted. But what happens is AppleFan.kext, AppleCPUThermal.kext, AppleThermal.kext, and the plugin package AppleACPIThermal.kext plugin cause the booting SSE2 kernel to panic. I just moved them to .kext.backup for now, and at least it boots ( I don't know for how long, but so far so good. )


Lots of other posters have noticed this, so it is nothing new -- although my system's fan runs at full speed all the time anyway, so it is kind of irrelevant to me -- though it might be to you if you are not on my exact system.


Also, the AppleEFIRuntime.kext will not work with the SSE2 kernel, so make sure that kext is removed too.


In my setup, the boot goes from either Lilo or Boot0 on the boot sector, to boot1h (installed either by diskutility, or the command line dd if=boot1h of=/dev/rdiskXsY), and then boots somehow from boot1h to the blessed boot file known as -startupfile in everyones good instructions all over the net.


The extra program floating around "startupfile" scares me, as BrazilMac doesn't use it -- and I never did get it to do anything useful.

It might work, but I don't know.


I also discovered that one can't issue the desirable bless command:

bless -device /dev/diskXsY -startupfile final_boot_file_name


From the disk that you have booted from, eg: Don't boot into your hard drive using: -v rd=/dev/disk0s1

and then expect to be able to bless the drive disk0s1. The reason: You can not use the non-fake binary bless to bless a mounted partition --> it will happily tell you by itself no matter how many times or ways you try that it won't work -- and you can't unmount root '/'.


Also, if you want to waste lots of time, imagine that the -startupfile parameter used by bless is *on* the unmounted disk to be blessed and booted.

That idea wastes looootttttssss of time, who knows what you will actually boot using if you think that way...

I'll let you figure out the right thing to do. There is plenty of documentation around the forums. :P


So the system boots, goes into 256 color vga mode 1024x768 with the 256 color pallette being quite wrong for the picture because the VESA BIOS is messed up and won't do a true 16 or 32 bit color mode -- and since the pallette gets loaded from the boot screen which should normally show the apple logo everything is in odd black and white and grey shades -- so I need to find out what the proper color scheme is for 256 color mode and fix that.... But at least it runs now.


I have modified the original booter to see if forcing the 1280x1024 mode VESA number 0x11B would work -- but it doesn't directly, so it looks like the video BIOS will need to be re-flashed for this system to work correctly either with Linux or OS-X -- I have an idea for a shortcut in ram... will be trying it out shortly for Linux at least ...

Link to comment
Share on other sites


  • Create New...