Jump to content

Asus G1S Notebook

3 posts in this topic

Recommended Posts

Hi All,

I figured I'd create this thread and hopefully everyone can input what they've done to get OSX86 running perfectly on their Asus G1S. I've searched the forums and theres information scattered througout. But it would be nice if all issues related to this laptop could be consolidated to one thread.


So far what I've done is install using the Kalyway 10.5.1 DVD using Vanilla Kernel, and EFI_MBR. I have a triple boot system with XP, Vista, and Leopard. I can report on this if you'd like to do this as well.


For most of the install I've pretty much followed npcomplete's guide which can be found here:

npcomplete's guide


The problem I'm currently having is that I get no Audio. Can anyone shed some light on this as I've tried almost everything I can think of? The hardware profile says "No Built-in Audio".


Otherwise everything works aside from Wireless, Audio, and occasionally my built-in Webcam.

Link to comment
Share on other sites

Do you have a more detailed list of how you went about installing osx?


Background - I have an Asus G1S currently dual booting (using GRUB) with Vista and Ubuntu. Depending on how well this works I may add osx as a triple boot option. Before I dedicate the HD space I want to get it running using an external USB hard drive.


I have read over the link that you provided and am not sure about updating the ACPI stuff. Reading over the link for the ACPI kexts, I am not sure why I would need them or which method to use, because the Kalyway disks boots successfully for the setup.


Also I am a little confused about the order of installation as well. When do I actually perform the installation, after booting with the cpus=1 diskxsx? Or after updating the kexts?


Here is what I have tried so far:

I have created a FAT32 partition on an external hard drive. When I boot using the Kalyway 10.5.1 disk with cpus=1, it gets me to the setup screen. Then I begin the install, select my usb drive as the target device and hit start, it begins the installation process. Then partway through I get an error stating not valid install or something to that effect during the installation and it exits out. I will try again tonight to get the name of the exact error.


Any help would be appreciated.



Link to comment
Share on other sites

  • 2 weeks later...

Finally, I have got it installed thanks to npcomplete's guide mentioned above. I haven't got it all sorted out but I wanted to make a post to clarify somethings in the post that may help others. I installed it to an external usb 160 GB drive.


OSX86 Disk Used:

Kalyway leopard 10.5.1

Hardware Used:

Laptop used: Asus G1s-A1, C2D T7500, 2GB Ram, 160GB SATA hd, touchpad, 1680x1050 resolution, Wireless.

Hard Drive Intalled on: Western Digital Pasport 160 GB External USB Drive. (will be reformated so beware)



  1. Boot from DVD, press F8 immediately upon the Darwin boot screen.
  2. At the command prompt typed "vanilla cpus=1 -v rd=disk1s2" (w/o quotes) This step got me further than I had gotten in 2+ months of off and on trying to load OS X. This takes a while to load since there will be lots of reported errors. Just wait it should ultimately boot to the installer.
  3. On installer load followed on screen commands untill kayway's instructions that he replaced the mac osx license with. At this screen whent to the top of the screen and clicke on tools and selected the Disk Utility. Using Disk Utility I chose the root of the drive and chose to partition it with mbr partitioning scheme. I chose two partitions one hfs+ and the other FAT. Finished the utility and closed it out.
  4. Continue with install and chose to install to the external USB and the partition I labeled OSX86.
  5. On one of the install screens the option to customize was present. Selected custom items and then completed the install.
  6. Completed install and rebooted. (I chose the MBR partitioning scheme because it is easy it get the windows boot loader to load and since it is on an external drive I didn't worry about the xp partition being deactivated.)
  7. Loaded XP and using macdrive7 copied the chain0 file into the root of C and added "C:\chain0="OSX86 Leopard" at the bottom of the boot.ini file. This will now give me a boot option on windows start up that when selected will point to the Leopard install. (I had tried a GUID_EFI partion scheme prior but was unable to get it to boot. So this worked for me.)
  8. replaced ACPI and APIC kexts with ones from tiger 10.4.8. (found on npcomplete's post) and deleted the files in his post under 2.f.
  9. Reboot using cpus=1 -v -x

This just got me to a bootable installation of OSX. Now The Fun Begins. Doing things like loading nvidia 8600m GT drivers so I can use my screen (currently at 1024x768) need to be done next.

Link to comment
Share on other sites


  • Create New...