Jump to content

Kalyway 10.5.1 on Toshiba Tecra M4 Tablet


1 post in this topic

Recommended Posts

Just want to report on my progress with Kalyway on my Tecra M4 (1.8GHz Pentium-M, GeForce Go 6800GT, ADI1981B audio, Intel pro wireless 2915abg, Marvell Yukon 88e8053 pci-e gigabit ethernet).


I hope this will be useful to others and of course if anyone has any suggestions for making further progress they would be welcome. In particular it would be good to get some kind of networking working as without that the machine's usefulness is limited.


I did a number of installs before I had success. I found that I needed to install OSX on the first partition, or I would get endless errors about 'Still waiting for root device'. So to get going, I:


- partitioned disk with disk utility in two, with first partition for OSX and second partition formatted as FAT; both done as MBR

- selected just SSE2 kernel, and MBR boot loader. I tried the various sound options; none made my sound work but they didn't prevent the install; selecting any of the video options DID prevent the install

- after the base install was done, on first boot I kept cycling through Welcom - Set Keyboard Type - Migrate Settings? over and over; I got around this by entering "Graphics Mode"="640x480x32" at the boot prompt (only needed once)

- for dual boot, the way that worked for me was to install chain0 and ntldr (from Windows 2003) on my Vista C:\ directory, and create an appropriate boot.ini. Trying to use the Vista boot property editor directly didn't work for me. When I select OSX from Vista boot menu I still have to quickly use cursor keys on OSX boot to select the OSX partition; it seems to select the Vista partition by default (as it is active?). This is annoying but as I use Windows much more it is acceptable. If I used OSX much more I'd probably not bother with the Vista ntldr trick at all and just make the OSX parition active.


I have no networking working. I tried the iwi driver for wireless and that caused crashes. As far as I can tell the driver for the Marvell Yukon is already present, and has device and vendor IDs that match my card, but despite this it is not detected.


No audio detected either.


For video, if I install NVinject, then I get white out or other artifacts on my display. I presume this is due to an incorrect NVCAP setting. I've tried the tool to get NVCAP from the video BIOS dump but it produces no NVCAP output.

Link to comment
Share on other sites


  • Create New...