Jump to content

"Chain Boot Error" after restore on dual-boot system


4 posts in this topic

Recommended Posts

Hi, I have recently installed Leo to dual boot with Vista following devilhood's EXCELLENT guide over the past few days and all's going well.


However, I tried to clone the OSX partition onto another HDD partition and when i restored it there was a "Chain boot error".


The details:


1. Vista previously installed on disk1 partition1. A partition on the SAME hdd was made with id=af ready for OSX (as instructed by the guide)

2. WIth the OSX installer disc, i went into Disk Utility and partition+erase another 2nd internal HDD (disk2) for future OSX backups.

OSX was then installed on to first hdd.

3. Vista boot loader repaired and with EasyBCD, I can load into both into Vista and OSX.


Problem with backup and restore:

I tried the Disk Utility (from within OSX and within Installation stage, SuperDuper, Clone Hatchery.

I will back up my OSX partition to the 2nd HDD (disk2) partition , then restore it back to my OSX partition on disk1.

When i restart, boot into VIsta is OK, but when i boot into OSX, I got the "Chain Booting Error"

The id is still AF. I cannot work out why this is so. Is it because the backups done are rendered unbootable somehow? or the bootloader did something funny?



Hope someone will help. Thanks!

Link to comment
Share on other sites


  • Create New...