Jump to content

Slow boot - IOKitWaitQuiet?


InfernalEternal
 Share

4 posts in this topic

Recommended Posts

I just installed iAtkos 1.0 (Leopard 10.5.1) and noticed that it takes an unnecessarily long time to boot. I have sufficient hardware (Q6600, 2GB RAM etc) so thought it would most likely be some sort of software conflict. I just booted with the '-v' and took some notes. The system seems to hang for 30-odd seconds when 'IOKitWaitQuiet' is mentioned, below is what I managed to take down.

 

NTFS driver 2.0 [Flags: R/0]

NTFS Volume Name, Version 3.1.

Kextd[10] IOKitWaitQuiet () timed out waiting to write kernel

 

There is another line that mentions something about an "Interface Namer" in reference to "IOKitWaitQuiet" but I cant write it all down, it is only displayed for a fraction of a second before the desktop appears. Ive done a forum search and the only other topic relating to this problem went unsolved, someone did mention something about deleting "AppleHWSensor.kext" though? Any help would be greatly appreciated.

 

Also is there an option to make the system save a transcript of what '-v' returns on boot? If not I guess I will repeatedly restart and and write down the final line one word at a time.

Link to comment
Share on other sites

In my BIOS I changed 'SATA Port0-1 Native Mode' to "Legacy IDE Mode" but now on startup I get the dreaded "still waiting for root device" message. Hmm. Might be due to the fact that both my HDD and DVD are SATA?

 

Waiting on IOProviderClass, IOResources, IOResourceMatch

boot-uuid-media, still waiting for root device...

 

EDIT: I did some research and followed these instructions. Changing SATA Mode to "Legacy IDE" removed the IOKitWareQuiet error, and the instructions which I linked to fixed the "still waiting for root device" error that the SATA Mode option change brought upon.

 

Initial boot times were anywhere up to and past a minute, now its a hair under 30 seconds. Excellent!

Link to comment
Share on other sites

 Share

×
×
  • Create New...