Jump to content

Can only boot into "Safe Boot" w/ vanila -f -cpus=1 command at boot


1 post in this topic

Recommended Posts

distro i installed: Mac OS X Leopard 10.5.1 for AMD SSE2/SSE3 (32bits)

When I try to boot to this after the installation I get a line of code thats says what kernal version it is and who wrote it and a few other informational facts. I cant get any further than that. Someone in IRC told me to type this command at the boot:


vanilla -f -cpus=1


This worked but then at the login screen it says safe boot which I assume is macs safe mode or whatever. How can I boot into normal mode. Also this guy also told me to edit this file in terminal:


nano Library/preferences/systemconfiguration/com.apple.boot.plist


He told me to change the part under <key>kernal flags</key>

<string>-v legacy</string>


He told me to change the -v to -x and I dont know if I was supposed to leave the legacy there or not. He says if I changed this then I wouldnt have to type the vanilla flag thing at the boot:


Also I tried to change this file but when I chose to write it or save it or whatever it said error. How do I sucessfully change that file.



Information about my computer I'm installing on: AMD 64 3200+, Biostar Tforce 550 mobo, 7600GT video card, IDE hard drive


I've gotten so far in this installation and I don't wanna abandon it now. Thanks for all the help from you guys at insanely mac.

Link to comment
Share on other sites


  • Create New...