Jump to content

Broadcom Ethernet BCM5789


11 posts in this topic

Recommended Posts

Hi guys.

First of all i want to say that before creating this topic i have tried so many times to get this ethernet card working using the broadcom 5701 and 5751 kext posted by someone (i don't remember the users) in my Acer Aspire 5673wlmi notebook without success.

I have also tried to edit the info.plist adding my dev id but nothing,when i go in the system panel then in network and ask to show all my network hardware i see Integrated Ethernet but i can't activate it (like it is hidden).


So i'm writing this topic hoping that someone that have the same problem can help me posting a solution and relative edited kext.


Oh i forgot to say it..i'm using the Jas 10.4.8 Intel SSE2 SSE3 with PPF1 & PPF2 and i have upgraded the kernel to 8.9.1 because i need it for the CPUThrottler.


Thanks in advance

Link to comment
Share on other sites

My card is BCM5789,b4 i use 10.5.1,it's can be activated by changing 2 kexts(AppleBCM5751Ethernet.kext and IONetworkingFamily.kext).

But now,i use kalyway10.5.1,the card can be autoactivated when installation finished!

I dont know which kexts can help u?if need ,tell me!

Link to comment
Share on other sites

no change unfortunately ;)


i've followed line by line the instructions written in the readme file.


i'va rebooted the system,logged in,gone to the terminal and i wrote the sudo ifconfig en0 ether (my mac address)


the shell returned me a message something like "interface en0 does not exist".


in fact the Integrated Etherned is always hidden and i can't enable it.


for understand what happen i have tried with the -v command,it is very fast to read exactly what is written (how can i retrieve the log?) and


it says something like BROADCOMBCM5789 mapping 0.


is it possible that these kexts have dependencies with other kext that i don't have? what else can i try? it's incredible


ps: here's exactly the id of my ethernet card taken from windows vista



Link to comment
Share on other sites

  • 5 months later...

Basically, i've got Broadcom BMC5787(Broadcom NetLink Gigabit Ethernet) appeared on my Acer 2920z. I can assign IP, DNS, Gateway... since MAC Address is all zeros, thus DHCP won't work(particularly my router). i can ping to yahoo, to hosts on the internet but safari either chat applications...


There are 2 problems:


1.Can't change MAC Address(Ethernet ID) , everytime i do the command "ifconfig en0 ether xx:xx:xx:xx:xx:xx" the system is hang. I getta hold the power button to turn off.


2.If I don't change the MAC Address(it's 00:00:00:00:00:00 everytime) whenever i open safari or chat, after few seconds, system hangs and must hold the power button to turn off. So far except for safari and chat application, with terminal i can ping to internet hosts and so on...


Now i start to look for the solution, if i would found it, surely i will post it here. :)


Anyway, thanks to all geeks who can make the hopeful situation so far.


Best regards,


Louis Tang.

Link to comment
Share on other sites


  • Create New...