Jump to content

Leopard 10.5.1 on Inspiron 1720


trogdor1138
 Share

4 posts in this topic

Recommended Posts

Hello all! I'm new to the forums and trying to install OSX 10.5.1 using iATKOS 1.0i on my Dell Inspiron 1720 laptop. My hardware is as follows:

 

Intel Core 2 Duo T7500 @ 2.2 GHz

Intel 82801HEM/HBM SATA AHCI Controller

Toshiba MK1237GSX 120GB Disk

Toshiba MK1246GSX 120GB Disk

2GB DDR2-5300 RAM

nVidia 8600M GT 256MB video card

SigmaTel STAC 92xx Audio controller

Broadcom 440x ethernet

Dell Wireless 1390 (Broadcom-based WIFI)

 

My hard disks are set up as follows:

 

My primary hard disk is still as it was set up in the factory. It has five partitions, which are used variously for Windows Vista, a recovery partition, Dell's quick-boot media player, and I'm guessing some sort of OEM boot loader, for use with the MediaDirect button which launches the player when the laptop is off. These partitions are untouched, as I wish to leave it as close to factory defaults as possible. I use Vista's bootloader to boot into Vista or XP.

 

I added the secondary hard disk myself, originally for Windows XP. It now has three partitions, one for Windows XP, a 5GB FAT32 partition I want to use as a swap space for trading files between my various Windows installs and OSX, and then a 15GB partition I set up in Diskpart which is the intended partition for OSX. The OSX partition was set up according to various install guides I have read, namely using Diskpart with the "id=af" option and then marking it active. I want to keep Windows XP on this drive as I am an avid gamer and have put the XP pagefile on the Vista drive for best performance.

 

So far, I can't even get into the setup for OSX. I boot from the DVD, and it seems to identify its intended partition, as there is a line stating "BSD root: disk2s3, major 14, minor11". However, the initialization stops at the line:

"localhost DirectoryService[51]: Launched version 5.0 (v514)"

When this line first appears on-screen the DVD continues to read for a few seconds, then stops. There is no hard drive activity, and the process won't proceed, just halts. As far as I can see, there are no real error messages. A few lines above, there is this:

"localhost kextd[47] can't add repository (not a directory)"

"localhost kextd[47] root filesystem is read-only; skipping kernel link data generation"

I can't seem to get it to progress past here. I am starting the process from the Darwin process using "cpus=1 -v" as recommended by a few install guides. Does anyone have any suggestions as how to proceed? I have a GParted Live CD if necessary for any more partition setup and am comfortable using it. Thanks in advance for any help.

Link to comment
Share on other sites

You may want to try a different release and see if the problem persists.

 

Brazilmac worked well for me on multiple occasions, and while I have not tried it, Kalyway has worked for many as well.

Link to comment
Share on other sites

  • 1 month later...
  • 6 months later...
 Share

×
×
  • Create New...