Jump to content

BCDEdit not working, tried everything


2 posts in this topic

Recommended Posts

I can't follow these instrucitons http://inihilist.wordpress.com/2008/01/07/...and-fool-proof/ when it comes to this:

34. bcdedit /copy {current} /d “Mac OS X”
Type bcdedit /enum active
Type bcdedit /set {GUID} PATH \chain0


The top command, bcdedit /copy {current} /d “Mac OS X” doesn't do anything at all, I just get an error:

A description for the new entry must be specified.

Run "bcdedit /?" for command line assistance.


I've also tried several other ways of making a successful boot screen but the best I've been able to make is a screen where you can choose between Windows and Mac OS X where Windows works but when you try to run Mac OS X it displays the Darwin bootloader countdown and when it's expired it starts counting down again.

Link to comment
Share on other sites

  • 1 year later...

The right is this:



bcdedit /copy {current} /d "Mac OS X" <- here you need quote before and after of Mac OS X



bcdedit /enum active


bcdedit /set {GUID} PATH \chain0 <- here you need to see the GUID numbers: to see type: bcdedit and copy the text between the {}


Just one more thing for this to work you need a working HFS+ partition on the SAME HD of the chain0 file.

Link to comment
Share on other sites


  • Create New...