Jump to content

NVDResman NVDANV50HAL and Geforce loaded improperly


3 posts in this topic

Recommended Posts

Ok, let me first tell you what i did.


i installed iatkos r2 with stock kernel, full efi and realtek lan drivers. After that i installed AppleHDA and ALCInject via Kext-Helper for Sound (899a).


Then i did the Kalyway 10.5.2 Update, after that i got IOPCIFamily 1.5 differs from requested 1.5.1 version bla bla kernel extension stuff for my lan.


Fixed it via my Backup of kext and took the 10.5.1 IOPCIFamily.


After that i took the vanilla kernel from kalyway, worked fine everything.

Rebootet, repairpemissions, Installed Graphic Update via Updater. worked also fine.


Then i got the same 1.5 IOGrraphics differs from requested version 1.5.1

-> kext load/link error for Geforce.kext


Ok, i took the 1.5.1 kext IOGraphics from my backup and replaced it with the one from the update.

ok, error gone.

now after booting, in mac os x leopard it says NVDresman.kext NVDANV50HAl.kext and Geforce.kext loaded improperly.


Cant change resolution and no quartz enabled and so on.

I have a 8800 GT 512mb from Palit.


Help would be awsome.

Link to comment
Share on other sites

ok, another point. i just did kextload and i get get error because of permissions, now i did chmod 755 and ican load it.


but i get some problems, it says System.kext/Plugins/IOKit.kext/IOKit : undefined in symbol set: _ZN1



only happens with 5.2 kext, not with the 5.1 one

still no 8800gt support

Link to comment
Share on other sites


  • Create New...