Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


how to install kalyway on virtual box?

2 posts in this topic

Recommended Posts

Here's the process with VirtualBox to get Tiger going, for reference purposes:



This is really compelling, because VirtualBox beats VMWare in terms of performance when running deadmoo. And VirtualBox is free, open source, and available for even more platforms than VMWare!


It seems possible to use VirtualBox with Leopard too:



Problem is that I can't get it to work. I've been using the pcwiz vmware vmdk as a handy starting point. Even with safe mode, adjusting the res down, setting all the backwards compatibility flags I can think of (-f, x86pc, etc.) I can't get it to fully boot. It loads the kexts, then VirtualBox either just abruptly closes, or reports a fatal error and gives a logfile that is (to me) both long and meaningless.


I've also tried almost every combination of settings in VirtualBox. Nothing seems to work. I've tried the native and ToH kernels. I will occasionally hack at it, but if I knew the source of the issue, it would go so far in helping guide the process.


Another set of solutions for Darwin under Virtual Box:


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.