Jump to content

Problem dualbooting Vista and Leo


2 posts in this topic

Recommended Posts

I have two SATA hdd's: a WD Raptor and Hitachi on a P35DS4 motherboard. Installed Vista on the raptor. No problems. Then unplugged the raptor and installed leo on the hitachi. I used GUID parition map and Formatted as Mac OS Extended(journaled). Leo installed fine and can boot into it no problem.


Now I'm trying to dual boot. I can select in the bios which drive I want to boot from and the correct os boots up fine, but I want to setup a bootloader.



Attempt 1: Darwin bootloader

I see osx and a blank entry which should boot me to Vista but it doesn't. Osx works fine but if I choose the blank entry, I get an Invalid system disk (or something like that), press any key to continue...



Attempt 2: Vista bootloader and tboot

Chose the raptor as the first drive to boot from in the bios so now i get the vista boot loader. Copied the chain0 file from the DVD to my c:\ and added C:\tboot="Mac OS x86" in the boot ini. Rebooted and saw the Mac OS x86 option in the boot loader. When selecting that I get a "No hfs partition found" error. Tried chain0 and got a "chain booting error" Tried the "Repair OS X "HFS+ Partition Error" but still no joy.


Once again, I'd like to stress that I can boot to both OS fine if I select which drive to boot from in the bios. I just can't seem to get a dual boot working with a boot loader. I've been reading and trying to get this problem fixed for the past few days now so if anyone can point me to the right direction would be much appreciated.

Link to comment
Share on other sites

  • 7 months later...

Having the same issue here. GA-EP35-DS3L.


GUID Leopard on drive 1, MBR Vista on drive 2.


The machine will only boot Leopard if I have the Kalyway DVD in my drive, by letting it sit through the "Boot CD?" option.


Otherwise, the BIOS skips it and boots Vista. If I manually choose the Leopard disk for startup, It gives me an "Invalid System Disk" error.


Dual booting worked fine before when my Leopard install was on MBR - however you can't re-image MBR drives correctly so I have to go with GUID.


Any Ideas?

Link to comment
Share on other sites


  • Create New...