Jump to content

new hope for x800 - x850 alikes in 10.4.11 :)


4 posts in this topic

Recommended Posts

hi after reading a lot i finally got the CI/QE working, i did the things i

learned from other topics and some bios flashing:


at first: if you try this be sure to have a second pci gfx card available if

anything with the flashing goes wrong. read about biosflashing

gfx cards, you may trash your card. (but in most cases reflashable

with your orig bios if you saved it before starting!!!!)




EDIT: post two has working bios / step by step instructions!




ok so here i try in quick words :


get the following tools (techpowerup is a good place):


-RaBit Ati bios editor

-atiflash flash tool

-get gpu-z and BACK UP ORIGINAL BIOS!!!

-in the vga bios database at techpowerup search for bioses that can match your card:


ok backup done, then


flash your card with the bios you choose and reboot. if everything is normal,

go to osx. flashing basically like this:


put atiflash and biosfiles in one folder somewhere on your fat /ntfs disks.

use a bootcd to go to dos and maybe mout ntfs tool to get to your files.

once there try this


atiflash -ai ok some info , remember adapternumber to flash (one card = 0, be careful if you'Ve got onboard and external card)



atiflash -p 0 biosfile.bin (-f)


the -f is used to force flash regardless of different identification of the cards.


basically i downgraded my Asus x850xt to a an x800xl with this ATI.X800XL.256.Samsung20_041124.bin

i think this worked for osx drivers, because it has dev id 554d which many of the sucessful installs had and the version number at

the end of the filename was quite low compared to others and it it original ATI. before i tried 6 or 7 different ones with my original dev id 5d52 without luck. i mean they where ok in windows and dos but osx drivers showed only garbage and mouse.


this done get into os and edit your ati9700 kext info.plist and the file in /macos/ with the dev ids from

the new bios. check sgis post http://forum.insanelymac.com/index.php?sho...c=7579&st=0.

the one extra reboot he did is not necessary i think, just edit the files , check permissions and reboot.


thats it after reboot i had it all 'complete with mouse tearing' to quote anotherone of the good posts

that lead me here :wacko:


some more discussion:


-the bios downgrade makes it necessary to reinstall drivers in other os on you disk

-the performance loss is quite a bit, but kindof fixable as the 16 pipes stay open, only clocks go down.

fix this with manually editing your bios with rabit, and flashing it back once again. performance loss should be near to none.

-as install i had xxx 10.4.11 with option 'old kext from 10.4.8 to get Ci/QE on ATI'

-maybe different bioses give different amount of mouse tearing?

-i think this is a possibility to get it right for all up to now not working x800 -x850 cards



ok, everybody have fun with it and be careful about the backup and the second pci or onboard card

to flash the orig bios back if the card stops working!






ps: if this gets confirmed i can add to the wiki

Link to comment
Share on other sites

ok i experimented a little more and now

i am able to make it much more easy for anyone




-you need a windows system for the utilities

-i did like this on ASUS AX850XT PCIE so you need a card that is


PCIE, X800 - x850xt should work


-again: be CAREFUL, if you've never flashed a bios before i don't recommend this for you.



-get 2 things:


1. http://rapidshare.de/files/38541063/makeitmac.zip.html

2. a DOSBootDisk or Dos BootCD


-extract the makeitmac pack


-place 554f_atiradeon9700.kext.zip and 554f_Callisto_b008.zip somewhere you have access from your OSX system (usb storage i.E.)


-open gpu-z


save your original bios to file


-place atiflash + Sapphire.X800GTO.256.050207.bin

somewhere on a dosbootdisk or dosbootcd, so you can access it from DOS (plenty of tutorials on the net if you are new to this)


-reboot to dos


goto where you placed the files

atiflash -p 0 Sapphi~1.bin -f


-in case anything goes wrong with bios flash you normally can recover if you boot with your onboard gfx card

or other pci card and reflash backed up bios



-reboot to mac


-goto the callisto/ati files and extract


note following procedure credit to phoenix3200 read


i only a little simplified it with prepatched files for the new bios and id.



-open terminal for callisto install


sudo -s

cd <Drag in the directory where the extracted 554f_Callisto_b008 files are at>

chown -R root:wheel Callisto*

chmod -R 755 Callisto*

cp -R Callisto* /System/Library/Extensions/

rm -f /Library/Preferences/com.apple.window*

rm -f /Library/Preferences/ByHost/com.apple.window*

rm -f /Library/Preferences/ByHost/com.apple.pref*

rm /System/Library/Extensions.mkext

rm /System/Library/Extensions.kextcache



-display preferences should work now


-goto sytem/library/extensions and delete ATIRadeon9700.kext


-open terminal for 554f_ati install


sudo -s

cd <Drag in the directory where the extracted 554f_Ati9700 files are at>

chown -R root:wheel ati*

chmod -R 755 ati*

cp -R ati* /System/Library/Extensions/

rm -f /Library/Preferences/com.apple.window*

rm -f /Library/Preferences/ByHost/com.apple.window*

rm -f /Library/Preferences/ByHost/com.apple.pref*

rm /System/Library/Extensions.mkext

rm /System/Library/Extensions.kextcache




-core image and QE should work (with some mouse tearing artifarcts - try mouselocator)


-play chess :P



Link to comment
Share on other sites

  • 7 months later...

  • Create New...