Jump to content

10.5.1 Kalyway, really sluggish


3 posts in this topic

Recommended Posts

Hi peeps, I just joined this wonderful forum, and hope to develop my knowledge os OSX to help others.

Just made my first migration to the world of Mac OS, been using linux distributions for a few years now so I'm hoping it wont be too painfull :-)


Heres my Problem...

After a few hours messing around with the boot options (F8 vanilla, -v, -x, -f etc..) I finally found booting via -v let me install Kalyways OSX 10.5.1, all be it a very long install (around 2 hours till prompted to reboot)


While running the install, keyboard and mouse etc... were all running fine, nice and smooth, Now im booted back into the OS everything seems incredibly slow, kinda like the performance you'd expect from running it on a very low end machine.


The mouse movement and program execution is the worst, the mouse wont move smoothly accross the screen, it kind of jumps about and is very hard to control, the same with program execution and navigation, everything seems to be running at half pace.


And when i click to view the mac info (to see if both CPU cores are up and running) it usually results in a crash/reboot.


The setup options i picked in the customization menu upon install are as follows:


Nvinject desktop



I hesitated on checking the 'SSE2' box as I presumed that was for SSE2 only CPU's, and my CPU is SSE2/3, I also didn't check the vanilla kernel boxs, mainly due to when i tried to boot into the installer via F8 Vanilla it failed miserably. (I'm starting to think this may be my downfall)


My setup is as follows:



Intel Pentium D 805 2.66ghz (stock)

1GB PC4300 DDR2

MSI Geforce 7300GT

80GB IDE (PATA) formatted to Journal MBR

160gb/320gb IDE NTFS



Everything seems to work out of the box (all though audio not tested) I can change resolutions, setup dual display, Intel p/1000 Ethernet card is functioning.


I just can't figure out this performance issue, its almost as if something is hogging the resources, or a VERY bad GPU driver install...


Any help on the issue would be MOST appreciated, Thanks :-)


EDIT: I think I MIGHT have sorted it out for the most part, tried booting with cpus=1 and the mouse is now smooth along with most the OS, though the dock bar is still a little slow to react...any other options/drivers anyone thinks i may need to install, or any tweaks I'm still listening eagerly, as i get a feeling the last of the sluggish behavour is down to poor GPU drivers...MSI Geforece 7300GT 256mb.


Also when i click 'about this mac' still it just seems to take a slow refresh of the desktop, failing to open anything

Link to comment
Share on other sites

I'm gonna trying installing Leopard too today, but I've already installed Tiger on x86 a long time ago,,, and after installing Tiger it was also very slow and I remember the tutorial saying that I must delete a specific system file from tiger to speed it up. So I deleted it and everything was fine. Unfortunately I can't remember the file's name atm. =(

Link to comment
Share on other sites

If you do find out do let me know :-)


I'm starting to think that a combination of running from 1 core and P-ATA HDD's might be the issue.


I never managed to install tiger on this machine, when I ran the install, it took about 4 hours to complete the install and then sent me on a constant loop of trying to get passed the personal options (language etc...) that was using 10.4.8 JAS.


I'm also still get a kind of stall/crash when clicking 'about this mac' it eventually returns to my desktop with no previous programs running. I also get a similar result while trying to rename a file.


Anyone think it may be worth trying to run the install again, this time installing with the cpus=1 -v command, and attempting to install the vanilla kernel?

Link to comment
Share on other sites


  • Create New...