Jump to content

[Solved] Why can't I see my OSX partition from Darwin?


4 posts in this topic

Recommended Posts



It's been since Leopard launch and later hack that I was thinking of trying it on my computer just to evaluate the future purchase of a real Mac.


I thought I have read enough guides, howtos and information related to the different releases... but there must be something I'm doing wrong :P


All I want to do is install OSX in a 20GB HD I don't use for anything else and to setup a triple boot XP/VISTA/OSX (Vista and XP are already installed in another HD). So I format the entire disk with the Disk Utility and select the patches I think I need. The problem is that when installation is complete and the computer restarts, it boots from the dvd and darwin only shows one entry: the setup DVD. If everything had gone well, I should see the partition in which OSX was installed, shouldn't I? This is basically all what I get after trying iATKOS, iATKOSr2 and Kalyway...


Moreover, I have already setup the vista bootloader for booting OSX and when I select it a "Chain booting error" message appears...


Do I have to check any bootloader in iATKOS or Kalyway in order to make the OSX partition "visible"?

At this point I am, an incorrect selection of drivers wouldn't affect, would it?


I have spent all the day reading posts and reformating, so I'm a little desperate just right now (although I think with your help I'll finish succeeding :) )


My hardware is:

Celeron D 330 (SS3)

Motherboard with 865PE + ICH5

Nvidia 6600GT AGP

4 IDE HDs (1 for Windows, 1 for OSX, 2 for data)

Atheros wifi PCI card



Thanks in advance :P



PS: I'm not english but I hope everything is clear enough :)

Link to comment
Share on other sites

Ok, well, I'm not a Linux guru, but I think that in order for Linux to see your Mac partition, it needs to be in FAT32. This format is pretty standard for most operating systems. I would make an HFS+ Journaled partition for your Mac installation and then make a shared partition in FAT32. You should then be able to see your partition from Windows, Linux and Mac.

Link to comment
Share on other sites

Thanks pcmantinker, that will be useful later. At this moment, the problem I have is that I haven't a working (or at least bootable) leopard installation so I can't share data between windows and it.


I have tried changing my bios settings to boot directly from the leopard HD but in this case the computer doesn't boot. I doesn't load any OS nor show any error message.


Any other suggestion? Thanks

Link to comment
Share on other sites

Problem solved!!


I reinstalled Kalyway with the drivers for my graphics and sound card and deselecting bootloaders.

After the installation finished, I followed this guide http://www.digitmemo.com/articles/658/howt...ot-setup-guide/ and applied the Bootfix patch. And that's all! The configuration I had made in the Vista bootloader for the previous installations worked perfectly!


Now I have to make my wifi work and I'll be really happy :)

Link to comment
Share on other sites


  • Create New...