Jump to content

x1300 Mobility no kexts?


5 posts in this topic

Recommended Posts

'Allo smart people of the Insanelymac forum,

I have a most likely obvious error here, but being the newb I am its completely flummoxed me

and searching the forum has been no help


Im using cpus=1 in my Boot.plist to get the machine running


The problem lays with my x1300 in my Dell E1505

I edited the Info.plist in ATIRadeonX1000.kext to include the proper device ID (0x71491002)

Fixed the permissions and rebooted


and Quartz Extreme was not enabled

and the Kernel Extension Info says "No Kext Loaded"


any thoughts?


Many thanks in advance

Link to comment
Share on other sites

No one willing to help?



I have a Thinkpad T60 with the ATI x1300. I really struggled to get CI & QE running. All the tutorials told me to enter the wrong Device ID for my plist file.


adding Device ID of your card


Make sure you get the Device ID from what is listed in your System Profiler.

Select Graphics/Displays on the left side and note what is listed for your Device ID:


Reload Kext cache and reboot. IT worked for me after I almost gave up.

Link to comment
Share on other sites

  • 3 weeks later...

Datasiphon, I tried the following on a Thinkpad with x1400 (and device ID of 7145) running with Kalyway's 10.5.2:


Edited the /System/Library/Extensions/ATIRadeonX1000.kext/Contents/Info.plist, and replaced


<string>0x71461002 0x71421002 0x71091002 … </string>




As root, type in terminal window:

chown -R root:wheel /System/Library/Extensions

chmod -R 755 /System/Library/Extensions

rm /System/Library/Extensions.mkext

rm /System/Library/Extensions.kextcache

kextload -v /System/Library/Extensions/ATIRadeonX1000

The kextload command reported that the kext was loadable and then it proceeds to load it successfully. It still did not work.


Am I missing anything? Any ideas?


UPDATE: got things working by following some of the directions in this post.

Link to comment
Share on other sites


  • Create New...