Jump to content

Dual Boot: OSX 10.4.11 EFI / Windows XP - b0 Error


1 post in this topic

Recommended Posts

So, first of all, before i get flamed, i have read the forum, searched the forum, and searched google.

I found this:

B0 error
From OSx86
Jump to: navigation, search

The b0 error occurs on bootup, if no partition is active. A solution to the problem is to insert the OS X install cd without pressing any key. When the install times out, OS X should boot from the harddisk.

To make a partion active, do this:

   * Start Terminal.app 

   * Enter: 

sudo -s (enter your password)

fdisk -e /dev/rdisk0 (the disk number may be different on your installation, eg. rdisk1)

print (list all partitions)

flag 1 (sets partition 1 as bootable - might be a different number on your installation)

quit (answer y to save settings)

   * Now reboot the computer. You should now be able to boot without the install cd. 


Which describes my problem correctly, i can get into osx fine if i let the dvd time out.

I followed the instructions, but the partition was already set as active, i tried setting the other one as active, and rebooting, then tried switching it back, all to no avail.


lord-crendores-computer:~ crendore$ sudo -s
lord-crendores-computer:~ root# diskutil list
  #:                   type name               size      identifier
  0: FDisk_partition_scheme                    *149.1 GB disk0
  1:           Windows_NTFS Untitled           133.8 GB  disk0s1
  2:              Apple_HFS OSX                15.2 GB   disk0s2
  #:                   type name               size      identifier
  0: Apple_partition_scheme                    *2.4 GB   disk1
  1:    Apple_partition_map                    31.5 KB   disk1s1
  2:              Apple_HFS XxX_OS_x86_10.4.11_Install_Disc_Intel 2.4 GB    disk1s3
lord-crendores-computer:~ root# fdisk -e /dev/rdisk0
fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory
Enter 'help' for information
fdisk: 1> print
Disk: /dev/rdisk0       geometry: 19457/255/63 [312581808 sectors]
Offset: 0       Signature: 0xAA55
        Starting       Ending
#: id  cyl  hd sec -  cyl  hd sec [     start -       size]
1: 07    0   1   1 - 1023 254  63 [        63 -  280703682] HPFS/QNX/AUX
*2: AF 1023 254  63 - 1023 254  63 [ 280714848 -   31866912] HFS+        
3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
4: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
fdisk: 1> f 2
Partition 2 marked active.
fdisk:*1> write
Device could not be accessed exclusively.
A reboot will be needed for changes to take effect. OK? [n] yes
Writing MBR at offset 0.
fdisk: 1> quit


What am i doing wrong?


I'm thinking i screwed up the installation somehow. What version of EFI should i be installing?

I have an Acer 4202 Wlmi. And i've had the darwin bootloader working in the past in a dual boot situation like this using an earlier install disk (i think 10.4.5 ish)


There is a lot more options in this install, so i'm a little unclear about if i've ticked all the boxes correctly.


I do have a dual core cpu, and an intel chipset. Everything works fine, even my new wireless card works fine, i just got no bootloader, and can only boot into osx if i leave the disk in and let it time out :P


Any ideas?

Link to comment
Share on other sites


  • Create New...