Jump to content
InsanelyMac Forum
Sign in to follow this  
datdallaseg

Help with ATI Radeon X1300XT (0x71CE1002) on OSx86 Leopard 10.5.1 (iATKOS 1.0i)

Recommended Posts

Hi, I've seemed to hit a wall with this one.

 

I installed Mac OS X Leopard 10.5.1 using the iATKOS 1.0i installer with the Vanilla kernel and EFI boot. I am running my OSx86 Installation on an Intel Core 2 DUO 6600 Processor on a Gigabyte GA-P35-DQ6 motherboard. The installation went perfectly, as most of my components and peripherals are working just fine. I have one main problem, though: my video card. It's an ATI Radeon X1300xt (Device ID: 0x71CE1002). It has two DVI outputs and one S-Video output. I have the adapter connected to a Gateway FPD2275W TFT LCD Flat Panel Display via DVI. The System Profiler displays the following about my display set up:

 

Type: Display

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 256 MB

Vendor: ATI (0x1002)

Device ID: 0x71ce

Revision ID: 0x0000

Kernel Extension Info: No Kext Loaded

 

Display:

Resolution: 1024 x 768

Depth: 32-bit Color

Core Image: Software

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported

 

So, as you can see, Mac OS X Leopard does not identify my adapter correctly, and QE/CI is disabled, and I am stuck at 1024x768 resolution. I have tried a number of different methods in resolving this, including various versions of Natit which all resulted in a system hang at a blank blue screen, and inserting my Device ID (0x71CE1002) into the Info.plist file in the ATIRadeonX1000.kext Extension which resulted in a kernel panic. None of the ATI drivers included in the iATKOS 1.0i package seemed to work either, as one generated a black screen and the other a kernel panic. I have been troubled by this issue for several days and have been frustrated with over 20 re-installations. I would thoroughly appreciate any help from the members and experts on the InsanelyMac forum. I've tried to provide as much information for you all to make finding a solution as easy as possible. As a quick sidenote, the secondary ID for my adapter is 0x71EE1002. Please help me, I am so close to having a complete installation. Thanks!

Share this post


Link to post
Share on other sites
Advertisement

ATI x1300/1400 mobility does not work on 10.5.1. You can only get CI software enabled. Nothing you can do except for buying a new graphics card. I have the problem.

 

Install Mobility.kext

 

You can modify the resolution with or without the kext installed by editing com.apple.boot.plist:

sudo nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

 

This is my com.apple.boot.plist; Use your max resolution. Mine is for 17"

<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>"Graphics Mode"="1680x1050x32" -v platform=X86PC idehalt=0</string>
<key>Timeout</key>
<string>2</string>
</dict>
</plist>

Mobility.kext.zip

Share this post


Link to post
Share on other sites

x1300xt is not a mobility card, it's almost the same as x1600pro but still has it's own ID and the methods for 1600pro doesn't work :/

Share this post


Link to post
Share on other sites

then you're in luck! X1300 for desktop has been found to work for some people. I don't remember which thread it was in, but look for natit, nvinject, titan, atinject drivers

Share this post


Link to post
Share on other sites

Thank you :censored2: I finally got it working with this method =)

Hurray!

 

But still got problem - working only on VGA output, no DVI support

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×