Jump to content

Kalyway 10.5.1 on Gigabyte GA-P35-DS3L plz help!


7 posts in this topic

Recommended Posts

first of all i'm a newbie for OSX86 and realy want to try it out


Spec For my PC

M/B : Gigabyte GA-P35-DS3L

CPU : intel Core2Duo E6550@3.1Ghz

RAM : 2x1GB DDR2 800

HDD : 15GB IDE(For OSX86 Only) & 350GB SATA2(for Vista 32bit)

VGA : Asus EN8600GT Silent 256MB DDR3


LAN : on Board

SUOND : on Board


that about all!!!


well i have try install OSX86 (Kalyway 10.5.1) on 15GB IDE HDD and it install ok

but after finishing install and restart the system all i get is black screen and it stop there

(i have set every thing in BIOS as recoment)so if any one can help me out will be very cool

cos i'm so sick of Vista and my mac mini is too old & slow to run LEO

(that what apple shop tell me when i ask them if i can upgrade my Mac Mini from tiger to LEO {My Mac Mini is PPC G4})

so it will be nice to have LEO no my PC


so plz if any one know what is wrong plz plz Help me out by reply this topic or e-mail me at My E-Mail


Thank to you all very much !!!!

Link to comment
Share on other sites

I have the same motherboard and it is all running great on mine. (Including XP through Parallels)


1) Have you tried totally disconnecting the SATA windows drive?

2) What options did you install with Kalyway? MBR, GUID? EFI with Vanilla kernel? What about video drivers?

Link to comment
Share on other sites

The answer is here: http://forum.insanelymac.com/index.php?showtopic=72493


You need to fix the EFI bootloader, I had exactly the same problem.


You need a USB pen and the EFI patcher. Put the EFI patcher pack on the USB pen and reboot using the DVD... I used the boot_v8 and it worked perfectly.


It is time to patch EFI/Bios - the command is pretty straight forward, but you will need to know your RDISK information - if you don't know, at the terminal prompt type enter -


mount [enter]


it will spit back information like this:

/dev/disk0s2 on /Volumes/Storage 500 A (hfs, local, journaled)

/dev/disk2s2 on /Volumes/Storage 500 B (hfs, local, journaled)

/dev/disk1s1 on /Volumes/LEOPARD (hfs, local, journaled)


The Volume label you are looking for is the one you installed Leopard onto earlier.


At this point, you should exit terminal and load up disk utility

unmount the drive that you installed LEOPARD to, when done exit disk utility and go back to terminal to your USB drive


cd /Volumes/[usb drive name]/pc_efi [enter]


type the following:

./startupfiletool /dev/rdiskXsX ./boot_v5 [enter]

where rdiskXsX is the drive and slice identifier you saw in the mount command


in my example, mine is disk1s1 (just put an r in front of it)


It should write about 7 lines of text, and exit.


Quit Terminal.


Now back to Disk Utility, and do a repair permissions on your drive, this is optional, but it probably won't hurt - safe to do and it might save you another 20 minute bootup into the installer just to do this.

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...

  • Create New...