Jump to content

10.5.1 and iTunes 7.5 crashes


2 posts in this topic

Recommended Posts

Hi all,


I managed to Install Leopard 10.5.1 on my AMD. I used Tiger 10.4.8 and 10.4.10 (Tubgirl) before more or less out-of-the-box but Leopard was a little tricky!


AMD Athlon64 3000 Venice

Asus A8N-SLI Deluxe (nVidia nForce4)

NVidia GeForce 7600GS


I got a kernel panic due to my graphics card (NVidia GeForce 7600GS). I had to boot in safe mode ("-x") which lead me to the first start where one should create the user account. This was not possible either, as I had an endless loop after saying "Don't copy any data". So what I did is to copy the user account from a time machine backup of my Macbook. After that, I copied all of the GeForce and NV*.kext files posted in the long AMD thread. After that, I had Leopard with full support (resolution, Quartz Extreme etc.).


The "only" problem I have is that iTunes 7.5 crashes all the time, i.e. when opening the iTunes Store or when changing the view (i.e. to cover-flow). I tried to fix this by running this AMD CPUID Patch Tool. It didn't work, the program checked about 5500 files and found about 20 CPUIDs. When I wanted to patch them, it quit with an exception. Am I doing something wrong here? What exatly do I have to do with this tool?


Another thing I tried is to completely remove iTunes 7.5 (and all files related to it), use ONYX, clean everything up and install it again (from apple.com). But this also didn't work, same problems as before. Any hints?


Thanks in advance,


Link to comment
Share on other sites



I fixed the problem I had with AMD Patch Tool by Marvin. It crashed with the following log message:

* Marvin's AMD Utility v.25 - 2008.01.14  20:06:29
* Input arguments:
*	 target_dir="/"
*	 dmount="/"
*	 cat="leopard"
*	 do_run_cpuid_file="yes"
*	 cpuid_file="/Users/Marco/Desktop/AMD.Patch.Folder/2008.01.14_at_19.49/cpuid.txt"
*	 simulation_mode="no"
*	 undo="no"
 * Parsing cpuid file:  /Users/Marco/Desktop/AMD.Patch.Folder/2008.01.14_at_19.49/cpuid.txt
 * Patching files
--+ /Applications/Skype.app/Contents/MacOS/Skype
 +   File is fat
***   err059 - cpuid patch - patch verification ERROR
 *		-- patch address: E8A90B  base address: 00002dd0  cpuid address: 0032790b
 *		-- i386 offset: 00B64000  text offset: 00001dd0
 *		-- Found bytes: 660f  Search bytes: 0fa2
*** Trying to undo cpuid patches made prior to error
***   err070 - undo cpuid patching: file of patched cpuids not found


This Skype version was from my Time Machine Backup (which is from a Macbook running Leopard). It didn't start at all so what I did is to delete the application and to remove all Skype related files from the cpuid file generated by the AMD Tool. I deleted anything except the two quicktime related entries and then it worked.


iTunes 7.5 is fully working now! :)

Link to comment
Share on other sites


  • Create New...