Jump to content

Asus A6J - Totally distorted screen after boot (x1600 mobility)


5 posts in this topic

Recommended Posts

Hello there and thanks for a wonderfull community!


I'm certainly no computer guru but here it goes..


(Scroll down to the bottom for the errors I get)


I'd been thinking about installing Mac OS for months so recently I gave it a try on my Asus A6J. Since I didn't want to get rid of my current Win XP partition (too much stuff I just need) I thought about making a new 10 gb partition on this usb drive I had. And so I did.



I tried the Kalyway 10.5.1 install disc and found, to my surprise, that I managed to boot Mac OS on my 3rd install attempt (some people just don't read the instructions properly.. :P )

This is how I did,

First, I checked my processor with that cpu-z program. Turned out fine. (meaning processor was ss3)


With Win XP already installed on my laptop I created a new 10 gb partition on my USB drive (a 120 gb drive with some stuff on it). I formatted it as a FAT32 disc and named it "macos". It's mbr.


I burned the Kalyway image to a dvd with Nero.


Rebooted with that disc in the drive and usb drive connected.


Pressed Del to enter the bios settings and set it to display all the mumbojumbo tests instead of start screen and boot from USB device first and DVD as second, regular disc as third. Saved and Exit.


Pressed F8 when the computer asked me to (If I wanted to boot from the disc) and it started the darwin thing.


I typed -v vanilla (because I think it said I should somewhere) and pressed enter. A lot of loading begins...


Once I get the greeting and all that I fire up the Disk Utility and format the usb drive that I so cleverly named as a Mac OS format (Journaled) (Might not be the exact name but you get the point). Press format/reset/clear or what ever the button said and it finishes in like a minute. All fine.


Exited the program and got back to the install window again. I choose my "macos" partition who now is 9.7 gb free space on a 9.8 gb partition and click next. I confirmed that I wanted to install on that drive.


On the next screen I clicked on the customize (right?) button to select the drivers I needed (my computer setup basically). I select both the vanilla things. Ignore the ss2 processor driver since mine is ss3 (cpu-z, thank you). Select the ATI X1xxx video driver since I have a ATI Radeon X1600 mobility (THIS COULD BE THE ERROR I GUESS! Does that driver support mobility? What else can I do?)


I also choose the mbr drivers at the bottom and ignore the rest of the drivers since I'm not overly sure about the sound and wireless at this point.


It installs and reboots the computer.


I quickly pressed F2 to enter a preinstalled superduper boot menu (I think it's natively on Asus A6J) and choosed to boot from the USB device. Might not be needed but I think it's cool.


Another boot menu pops up and asks which partition I want to boot from. I choose "macos", naturally.


Darwin starts and I type "-v vanilla" just to be sure. Enter.


Mac OS boots. Yey!



To the problems,


when Mac OS boots up the screen is all distorted with pixelthin lines running across it in random order. Like the image repeats itself multiple times but shares the space among those instances. From reading the forums it feels like the ATI driver with Kalyway (ATI X1xxx) is not supporting laptops (ATI X1xxx Mobility). The NVidia driver is supplied as a desktop and a laptop version though.


Another thing I felt was wierd was that the install worked smoothly (display etc).


Any thoughts? (I tried to find the answer by searching the forum but I couldn't find this specific case)


Add: Just to clarify a bit more, since I can't really see anything except for what appears to be some kind of welcoming message box distortedly repeated over the screen I can't really access anything in Mac os. It's unusable. I have seen threads where other people have been able to boot Mac OS but had flickering cursors etc. That would be a progress in my case. I also just saw this thread, AtiEFI. Is that it?

Link to comment
Share on other sites



I have the same notebook (Asus A6j). I installed OSX86 10.5.1 by OSX86. TURK team:


After i downloaded the ISO, burned it on DVD, i booted it. Formatted my disk with the Disk Utility during installation with only one partition. After installation it works fine.

  • Sound works;
  • screen not that good, some arteffects, but i have visual at 1024x768;
  • Wifi won't work.

I searched this forum how to install drivers for my mobility X1600. But no succes. All solutions gave more problems(black screens, hang at startup).


Would you plz let me know when you installed your drivers succesfully, and post here how :) .


Link to comment
Share on other sites

  • 5 weeks later...

A6J here too.


sound, ethernet and bluetooth worked out of the box fine after installation with iatkos v1.0r1 (no patches or anything during installation, just basic install- no customise)


But my resolution was 1024x768. It is really not much fun to have a macos with that resolution.


Anyways I tried several things to have a native resolution but no chance... black screen or no backlight.


Now Im downloading kalyway... But I see that it is not going to help me with my screen resolution.


Hey guys if you find a solution for x1600 (specially A6J guys) please send me the solution.. please


Good luck guys...

Link to comment
Share on other sites

  • 3 weeks later...

Hi ppl.

I have a asus a6jc with GeForce GO 7300

I installed OSX86 10.5.1 by OSX86. TURK t.

at first resolution was 1024x768.

then I installed a drive named "NVinjectGo.0.2.0" and works like a mac himself.


xcuseme for my bad english.


good luck.

Link to comment
Share on other sites

  • 4 weeks later...

EDIT: Ok, it's actually like this. I redid what I describe below about the EDID and the screen turns up black after the logo. BUT, it's not entirely black. I just saw that the login box appears and I managed to shutdown properly with a bit of a squint. I looked around the forum and saw that there was another guy with the same problem, but no answers in that thread though. So, any thoughts?


add: ok it seems the discussion is going on in this thread; http://forum.insanelymac.com/index.php?showtopic=69345

but it would still be really nice if you give me a shout if you stumble upon the answer :( I'll buy you virtual beer or something



Did anyone find any working drivers for the Radeon x1600 Mobility?


I tried Aitkos but had the exact same problem there and went back to Kalyway. If I boot it up in safe mode "everything" works fine. That is I can surf via lan etc (no sound though but I know that works normally from the welcome message), but I would so love to get the graphics card to work with me.


I have looked at various solutions on the boards but haven't been able to get any of them to work (or understood have to do it I suppose).


I looked at this thread and tried his solution to no avail:



I think I got the right EDID but there's like 11 different entrys in the display list in Phoenix. I picked AUO1974 since I found someone else had used that one (who also had a Asus A6j). When I try it with that one the system hangs after the grey apple screen, sadly.


Hope someone has any hot inside info :angry:

Link to comment
Share on other sites


  • Create New...