Jump to content

x38 users speak up


4 posts in this topic

Recommended Posts

Foxxconn X38A motherboard (ICH9, jmicron)

Q6600 quad core cpu

Foxconn 8800 GTS PCI-E

3GB ddr2 ram

WD raptor sata hard disk

Liteon sata dvd & LG ide dvd.


the problem is, no mac os boots whatso ever, simply wont even get to the language selection screen. Tiger distros just get stuck in a rebooting frenzy and leopard hangs at IO buffer error.


I've tried every mentioned "-" command, ive unplugged every unnecessary device, changed just about every possible combination in my bios to do with ACPI and AHCI, disabled speedstep and multi-core support.


It's getting too frustrating to think of anything else to try.


I really need to know what settings other X38 users are using and what distros they are using. I've got just about every one handy.

Link to comment
Share on other sites

update: managed to get 99% of the way through the kalyway 10.5.1 installer, so I can finally confirm that the Foxconn X38A mainboard is compatible so far...


For those interested in knowing, kalyway 10.5.1 is the only distro currently that is booting on my system all others hang at the grey apple loader.


A few options must be turned on and off in the bios these are:


Multi-Core Processor set to "Disabled"

Speed-Speed Technology set to "Disabled"

AHCI set to Version 2.0

ACPI set to ACPI + IDE (Enhanced)

HDA Controller set to "Disabled"


at the darwin boot hit "F8" to enter startup options, followed by:




This is VERY important as it took me ages to realize I had to manually set this, every other time it would act like all the other distros and just restart before the grey apple loading screen.


However, with all this my next problem is right at the last "under a minute" remaining part of the installer, it will inform me that the installation has failed and gives the option to restart.


Can anyone shed some light on why this might be doing this? I've tried a handful of different options but so far have only installed using the GUID partition table with EFI for GUID, I'm currently trying to install leopard without EFI just to see if thats causing any trouble but if not, what else can I really try?

Link to comment
Share on other sites

  • 1 month later...

  • Create New...