Jump to content

Kalyway installed, *nearly* boots - beachballs upon first boot


3 posts in this topic

Recommended Posts

  • Intel Core 2 Duo E6600

  • Gigabyte GA-965P-DS3 rev1.0 (onboard sound) (F12 BIOS)
  • eVGA Nvidia 7950GT 512MB


The Kalyway DVD seems to have installed fine :D , but upon post-install rebooting, the system will show the white Apple logo screen, then the screen goes black and I see both a cursor and a beach ball prompting me to wait. Waiting for half an hour and it was still there.


Tried installing with both vanilla and -v -x as a DVD boot options. Do I just force a reboot when it says "MACH Reboot"?

Side note: Using -v -x seems to have rebooted the system very abruptly upon install, like it didn't prompt me at all.


Tried without System_SSE2 and then with.

  • --^ Do I need to do this? C2D is SSE2 and SSE3 I believe.. (edit: answer is no, do not use SSE2 for a C2D, only for SSE2-only CPUs)

Used audio patch for the DS3 (last one) and the Nvidia patch for 5000/6000/7000 cards

  • --^ I wonder if the video could be the problem? Any advice?

I would appreciate any help -- I can't believe how far along it got! It looks to be nearly there, just something is hanging it up.

Can't wait for this to be set up... will be nice to go along with the AppleTV and iPhone.


edit: wanted to add: one thing i noticed with the non-vanilla install is that it flickered the OS X blue fancy image background in between apple white logo screen and black screen / hang.... looks like #10 from http://osx86help.we.bs/index.html maybe


also noticed this: http://nvinject.free.fr/forums/viewtopic.php?t=26


okay, supplemental info!!

when I installed Kaly Leo I didnt choose any video options on the installer. So when the install finished i could only get 1024x768, no QE/CI, and no resolution changing. So i went to:




and downloaded 'Natit_Dual_v2.0' (even tho i only have 1 monitor).


unzip it and copy the Natit.kext into /System/Library/Extensions/


cp -R /location_of_downloaded/natit.kext /System/Library/Extensions


then i edited the kext with my nvidia video card device id. I have an EVGA 7950GT (256MB) and it's devID is 0295. and 10DE is the vendor ID.


use vi to edit the file:


vi /System/Library/Extensions/Natit.kext/Contents/Info.plist


and change what is in the <string> tags under IOPCIMatch to your devID and venID.








in the downloaded natit.kext there is a bunch of {censored} in the <string> for IOPCIMatch just delete it and your ID always should start with a 0x_______.


then make sure the permission and ownership is correct.


chmod -R 755 Natit.kext

chown -R root:wheel Natit.kext


reboot and that should be it.



I noticed you have a 512 card. did you flash the card? I think that OSX has problems with vid cards of 512 memory. but there is a way to flash it to work. but i'm not completely sure about if leopard requires it. there's a thread on IM about it. just search for it.


good luck.

how to get your card's devID and venID:

the easiest way for me was to use windows

1. right-click on 'My Computer'

2. select 'Properties'

3. select 'Hardware' tab

4. click 'Device Manager' button

5. expand 'Display adapters'

6. right-click on your video card

7. select 'Properties'

8. select 'Details' tab.

9. and it should display something like:

PCI\\VEN_10DE&DEV_0295 ......


so it's 0x029510DE for me




i think you can use a live linux cd too. at command prompt type:

lspci -vn


i think try some different switches.

Link to comment
Share on other sites

Got vanilla working! Skipped the video patch for now, going to apply a new ROM to the video card then try again.


Wireless Linksys WRT54G broadcom 43xx worked without having to do anything, going to try to get sound working too.


Pretty easy, didn't have to do much, just wanted to post my hardware.

Link to comment
Share on other sites

Woohoo! Darwin now detects 512mb at startup on the 7950GT, I flashed the nvidia bios using this guide: http://nvinject.free.fr/512Mb.html (more ROMs available there too)


Whereas it previously showed just a black screen & cursor, now it goes straight into the login prompt at 1900x1200 :)

Power save works perfectly too.


In regards to creating a boot disk, I connected a USB floppy drive to OS X running parallels XP and chose to format -> create ms-dos boot disk

Luckily I had enough space to include all the necessary files, let me know if you'd like an image copy. It might work off a USB pen, who knows


Audio is up next, I'm pretty sure it's a real quick hex fix or something


Cheers all, I hope this helps someone

Link to comment
Share on other sites


  • Create New...