Jump to content

OSX Leopard 10.5 on a Dell XPS1210 - Howto


2 posts in this topic

Recommended Posts

Finally got the XPS1210 sort of working with the leopard-x86-flat-img download. The installation to a external USB hard drive was pretty straight forward, though all of the important peripherals on my computer are not yet working.


I am running Ubuntu right now so I just did

dd if=/leopard-x86-flat.img of=/dev/sdb, which will write the image from my root folder to an upartitioned USB drive in /dev/sdb (be sure to change that if your USB HDD is on another bus). Once that finished, I rebooted and voila, I was into OSX.


My system was running VERY SLOW though at this point. The mouse would freeze every few seconds and the freezes would last up to a minute! After some searching I came upon a solution. Apparently the Kernel isn't too good at recognizing my Core 2 Duo 1.66GHz proc. The system will only work properly with 1 core enabled & Apples powermanagement changed.

In order to get that to work, do the following (thanks devilhood)

1. Load up Terminal (Applications/Utilities/)

2. From within Terminal type:

sudo nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

3. Edit the Kernel Flags accordingly:

<key>Kernel Flags</key>


4. Hit Crtl-X, then type "Y", then hit Enter

5. type

cd /Library/Prefrences/Extensions

6. type

sudo rm -rf AppleIntelCPUPowerManagement.kext

7. Reboot


Once I rebooted, the system was flying!


The next issue I ran into was the fact that my network card (Broadcom 440x) was not working properly... or at all. In order to fix this problem, you'll need to download the XPS1210-Broadcom440.zip file that is attached and follow the following instructions:

1. copy the .kext to /System/Library/Extensions

2. Open Terminal and run the following commands:

sudo -s

chmod -R 755 /System/Library/Extensions/AppleBCM440XEthernet.kext

chown -R root:wheel /System/Library/Extensions/AppleBCM440XEthernet.kext

rm -rf /System/Library/Extensions.mkext

3. Reboot.


After that, you'll probably want to have power-management & be able to tell how much battery life you have left. In order to do that, please do the following (thanks keithpk)

1. Download the PowerManagement.bundle zipfile & extract.

3. Navigate to: /System/Library/SystemConfiguration

4. (Optional) Backup your old PowerManagement.bundle

5. Copy (drag-n-drop) the new bundle into the SystemConfiguration folder

6. When the dialog box pops up, select authenticate and type your admin password

7. Reboot


Now I bet you want sound, huh? If so:

1. Download the XPS1210-Sound.zip file attached.

2. Extract the two files.

3. Drag the codec_Sigma9220.txt file onto the AppleHDAPatcherv1.20 file.

4. When it finishes, reboot.


Bluetooth worked automagically, the DVD drive works, and now about the only thing that doesn't work right is the wireless. It's an Intel 3945 chip, and well, there dont seem to be any drivers anywhere that work. Oh well.




Link to comment
Share on other sites

  • 1 year later...

U just made my day :)

I've managed to install the network (the only thing missing for me) after several different attempts and stressful days :)


Now I must get the WIRELESS to work..


My DELL XPS1210 has just magically turned into a MAC!! :) That is soo good... ;)

Link to comment
Share on other sites


  • Create New...