Jump to content

100% working Leopard Install on a Budget System


mtakach
 Share

5 posts in this topic

Recommended Posts

Over the holidays I spent some time getting Leopard to install on a system my father put together on a fairly tight budget so that he could mess around with different operating systems mainly different versions of Linux, and his first Vista install, and he wanted me to try out OSX for him. After the install was complete, everything with the system worked completely, with an EFI install! So if your looking around for some budget parts, these may be what your looking for. His specs were

 

Gigabyte GA-965G-DS3

Intel E2140 (1.6ghz, dual core)

Seagate Barracuda 160gb, 7200 rpm, SATA

Nvidia Geforce 7300GT

Buffalo Select DDR2 667 (2x1gb)

Write Master DVD/DL RW, SATA optical drive

Netgear 3A11, gigabyte LAN card

 

Note about my hardware:

 

First off the E2140 was overclocked to 2.13ghz with the stock fan, it actually is read as an E6400 in the bios. I did not physically put the system together, my father tells me though that he did not try and overclock it, but that the system did it automatically, he did buy this board as an open box deal so maybe… Also the memory was overclocked to 800, I believe.

 

How I Installed Step by Step:

 

First off, I tried Uphuck’s iATKOS release, and it DID NOT WORK. I ran into the dreaded boot flag problem which seems to be plaguing a lot of people out there. So I tried out Kalyway’s release of 10.5.1 and this one did work with my hardware. It does not matter which SATA port the drives are plugged into on the motherboard, it also did not matter if the bios was set up for AHCI or IDE. I installed it on AHCI, then later my dad changed it back to IDE for some reason. It would still boot up fine, and I was able to install it on another drive in IDE mode as well.

 

Anyway, when you begin booting from the cd, hit the F8 key to enter start up options. Then type in “vanilla” this will boot the EFI for your install. The advantage of EFI is supposedly there is a slight speed increase, but you will also be able to download system updates from Apple directly through the software update rather than getting another patched release.

 

Once the install disc boots up, go into Disk Utility to format your drive. I would recommend that you do not use a hard drive with any information on it that you want, in fact using a separate hard drive for OSX is the safest and best way to do this, or you could create several partitions on one drive using Disk Utility, and after you finish with Leopard, install Linux or Windows (only if you’re a masochist) on those extra partitions.

 

But anyway for the preferred method, select the hard drive, then click on the tab which says Partition. You need to set your partition to 1, or more if you want several partitions. Make sure your format is set to Mac OS Extended(Journaled) Then click on Options and select the GUID partition. This format is newer/faster than the MBR, and will allow you to change partition sizes later. Some people have run into trouble trying to use GUID, but with this set up it worked flawlessly. Finally, click on Partition and wait for it to finish the disk.

 

Close out of Disk Utility and select the partition you just made as the destination for your install, and click next. Now click on the customize button, before you install, this brings up the drivers you want to install. For this selected

 

Vanilla_Kernel

Vanilla_ACPI_fix

(these are for the EFI)

 

NVINJECT_gfnvidia_desktop

(Nvidia driver for 7300GT, enables both CI, and QE, plus supports high resolutions)

 

HDA_ALC883 (DS3)

(for the onboard sound)

 

GUID_bootloader

(this option under Bootloarder EFI, makes sure it boots EFI for a GUID partition)

 

Then just hit install and walk away for a while.

 

At this point, you’d think that you had done everything needed to install right? Unfortunately I ran into a problem during my set up, which you have to complete before you can actually use OSX. The problem was that when I came to the “Transfer Information from another Mac,” screen, I would select “Do Not Transfer Information,” so that I could start a fresh computer with nothing on it. When I did this, the set up would stall, then loop back to the very beginning of the process even playing the welcome animation all over again. I got past this by installing an a copy of tiger, Kalyway’s 10.4.10 onto an old IDE drive and then booting back into the SATA Leopard drive and using that tiger install to transfer information, even though it was essentially empty. I started a thread about this and some people gave me some more eloquent solutions, if you would like to try them go here

 

http://forum.insanelymac.com/index.php?sho...mp;#entry556184

 

That’s the total install process

 

Note, the built in LAN did not work for me, but I think my dad broke the Ethernet on this board somehow, because he could not get it to work in Windows either. Because of this I cannot confirm/deny that it works at all, but I can confirm that the Netgera 3A11 gigabyte LAN card I installed worked like a charm. This has a Realtek chipset which is supported by Kalyway’s release.

 

Post Install:

 

The first thing you’ll notice when you finaly boot Leopard is that while Kalyway made a technically greate release, because it works very well, this guy is a total dickhead and he changed a lot of the default settings so that they are absolutely hideous, and not really the sexed out view you usually see with OSX. To fix this run Laik’s Virginizer, it restores Leopard to default settings. However, it is well worth looking at some of the extra programs that Kalyway installed and decide if you want to make a copy of them because the virginizer will remove them as well. Some of them are actually really good apps like Roxio Toast, or VLC. You can find the virginizer here

 

http://forum.insanelymac.com/index.php?sho...479&hl=laik

 

This however does not change the super annoying orange background color on EVERY folder (did I mention Kalyway was a jerk yet) so to fix this right click on the background of a folder, select “Show View Options” and select white for the background color. If you also hit “Make this Default,” it should change on all folders.

 

What I’ve Tested:

 

Adobe CS3

Burning DVD/CD with Toast

Running Azureus

General usage with various tasks

 

Impressions/Thoughts:

 

I’m actually very impressed with this set ups performance, because it is a budget system, while I do not know the exact amount because it’s not my pc, it is within the $500 price range, I think. The overclock on the cpu probably helps significantly (it’s about 30%). I was especially impressed with how fast it moved several gigabytes of information across hard drives, and using Handbrake to encode DVD’s I was getting around the average of 35fps, not too shabby in my opinon. It general runs very stable, maybe not quite as stable as my Macbook Pro, but for a hackintosh I'm not sure if you can beat it. One lingering issue which I cannot solve is that it does not shut down all the way. The whole computer shuts down except for the power source and fan; you have to hold the power button for a full shut down. However restart works, and it does sleep.

 

My xbench score was 117

My 17 in Macbook Pro, which is 9 months old, scored 100, the two were very close on most tests except for the hard drive test, my laptops drive which is only 5400 rpm, and almost completely filled, is what lowered the score. I’ve posted pdf’s of the scores if you are really interested.

 

Improvements:

 

Get the 965P chipset over the G, or better yet go for a P35, although they are probably more expensive. Also, if it were my computer I'd try to push the E2140 higher than 2.13ghz, since with the stock fan the heat sink was still at room temperature.

Macbook_Pro.pdf

Hackintosh.pdf

Link to comment
Share on other sites

  • 2 weeks later...

Wow, thanks for the detailed write-up!

 

I've messed with OSx86 on my PC occasionally when new releases came out, and I think now's the time to make the big jump. I'm encouraged by the fact that I have the same Gigabyte GA-965G-DS3 motherboard as you, the Kalyway 10.5.1 release, a spare SATA hard drive, and a SATA optical drive all ready to use. I'll follow your steps this coming weekend and report how it goes.

 

And if, by some chance, the onboard Marvell LAN doesn't work, what's 15 bucks for an Ethernet card when you just got a $700 "Mac Pro"? ;-)

 

Thanks again.

Link to comment
Share on other sites

Got it working! This is my first hackintosh setup that actually worked and has gotten me all the way to the Finder.

 

Installed on a 750 GB Hitachi SATA drive (connected to the onboard purple SATA ports instead of the orange; I had the HD on the RAID-ready ports instead of standard) using the Kalyway 10.5.1 disc.

 

I can confirm that onboard Ethernet works on the GA-965G-DS3 (rev 1.0 hardware, if it matters). Now I've got to mod the Radeon 9700 kext to get my Radeon X850XT working (link).

 

I'll keep posting here if I make any other discoveries.

 

Thanks again for the write-up!!

Link to comment
Share on other sites

 Share

×
×
  • Create New...