Jump to content

How the HP dv1000/dv1410 Leopard installation went


3 posts in this topic

Recommended Posts

Pointers on Atheros 5005 and Intel GMA graphics welcome !


I have run Tiger 10.4.8 on this earlier, and got everything working out of the box except the Wireless network. The original wireless was Intel 2200, so I acquired an Atheros 5005 wireless card instead of of eBay.


After patching the HP BIOS (they lock the BIOS to certain hardware such as specific wireless cards so you cannot just swap it for another type), things went fine. The card was recognized as an Airport card and I could connect to any wireless network just fine.


Graphics worked brillantly too. Out of the box, just needed to short pin 6 and 12 on the external VGA connector to obtain a picture on the laptop display. Resolutions and everything worked fine.


Now I reinstalled the laptop from a fresh start with Kalyways 10.5.1 DVD disc. I went for PC_EFI and GUID partitioning. Tried the Vanilla kernel with patches first. No go, so reinstalled without them (yes I realized afterwords I could have just booted the other kernel and replaced the vanilla kernel...but hey!)


Were not too fancy about all the customizing of the backdrop, and window colors and icons... Or the extra apps, though they are great in themselves. But anyways, a great disc, Kalyway!


In Leopard though, the Wireless will NOT work no matter how much I "hack it". I tried modifing the original IO80211Family.kext files, even hex edited the AirPortAtheros binary to match vendor and device IDs. I could get it to load the kext and let me know that it had an Airport card, but that it would always be off. I could not turn it on.


Replaced the whole IO80211Family.kext with the one from Tiger 10.4.8 that worked before... Nope, now it loads the kext but the Airport is always OFF. And it cannot be turned on... :D


Beside from this and that I cannot get QE/CI support by hacking the AppleIntelGMA950 files... Well Leopard runs just great.


Everything is superb. It can even go to sleep and wake up. And the About Mac shows correct info.


If anyone has gotten the Atheros 5005 or Intel 915GM/910ML/915MS graphics to fully work. Please let me know. The computer detects it as Intel GMA 900 graphics. Searching these forums hasnt led to any particular thread that has solved the problems yet. And Ive spent a few hours in the forums looking :(


The Atheros IDs are 144f and 7094. The Intel graphics are 2592 and 8086, revision 0x0003.


Thanks for looking :)

Link to comment
Share on other sites

  • 6 months later...

hello amuso, if you still go to this thread,

i was wondering how you got the hp dv1000 to work with the kalyway 10.5.1 dvd(leopard) . I have a hp dv1000 with pentium m 1.5ghz with 1g of rams and 60gb and intel graphics. I've recently installed Tiger 10.4.9 with succes but unsuccessful with kalyway. I used disc ultility to have 1 partition with guid table. When i installed i did not use the customize and add any other features just the guid boot thing. When installation was sucessful my laptop restarted and i get the grey apple loading screen. After a few mins the loading wheel freezes and is stuck like that. Everything just stops. Can you tell me what is wrong with the installation, did i do something that i was not suppose to or i forgot to do something i was suppose to do. Thank you


Link to comment
Share on other sites

  • 1 month later...

Sorry I dont have the laptop any more, so I cant try it again and see how I did it.


But I am sure I just partitioned, like you did, and then just selected the correct kernel to use (not any of the vanilla ones). Maybe I deselected, or selected some kexts from the installer to make it work... If you give me a list of the installers options I might recall which settings I set or unset.


Since I dont check the forums too often, just PM me and I will stop by and see if I can help.

Link to comment
Share on other sites


  • Create New...