Jump to content

Abit IP35 Pro + Kalyway 10.5.1 kernel panics


7 posts in this topic

Recommended Posts

I am at my wits end on this, I really hope someone can give me suggestions on how to move forward. I have installed Kalyway 10.5.1 on my rig (details in sig) and when I boot up, everything seems fine. If I start doing any "heavy" network traffic, I get kernel panics or freezes. I noticed this morning that the installation put in a Realtek 8139 kext, yet the chipset on this mobo is supposed to be a Realtek 8110SC (according to Abit website). I dont know if this is the cause of the problem or not. I never get any real network info in the system.log. And if I boot into safe mode, I can transfer files over the network forever without an issue.


I had thought it was a video card issue (Quartz Extreme) causing this, since QE is disabled in safe mode, but I reinstalled the whole OS last night and didnt install any video drivers, so QE is disabled in normal boot mode now as well, and still get crashes/freezes.


I also have an issue with the "About This Mac" window, it lists my cpu as "2.45GHz unknown" instead of "2.45Ghz Intel Core 2 Quad". I dont know if this is also part of the problem, or if this is merely a cosmetic flaw.


I guess I need someone to please push me in the right way from here. Do I try other OSX versions? Do I scrap the mobo and get another (suggestions? Bad Axe 2? Asus?). This mobo/cpu/ram combo is brand new and I have never tried another OS on it, so I guess its possible one of the components has a flaw too? I did run memtest though several times with no failures.


As it stands right now, the system is a complete virgin install of Kalyway. No updates done, no other softwares installed. If it matters, hard drives are setup as IDE not AHCI. The bios on this mobo dont seem to have an ACPI 2.0 section like my Asus P5B Deluxe mb (which I have successfully installed Kalyway on and its flawless!). I will probably try to install Ubuntu linux tonight on another HDD, and initiate some heavy network usage to see if I get any issues there, but honestly I think thats a long shot, since network traffic is fine in safe mode (doesnt this prove that the hardware works?)


I aprpeciate any comments any of you might have for me!

Link to comment
Share on other sites



Maybe you'd asked this in the IP35 topic... I'm sorry, I hope that it gives you some clues to get it work. AHCI versus IDE? Maybe, but why? GUI vs MBR partition? Why too?



I installed Kaly only choosing the right EFI for my MBR set, Natit for the 7600GT, leaving the other default checkboxes.




My rig is bought, made and set to run Windows XP the best it can. Any foreign OS I try, by curiousity or whatever, have to run on it as is. And don't touch to the "DOS" MBR, no Lilo, Grub would write my daily rig's MBR until maybe I decide to later switch to an other OS... Point.

Thanks to Wingrub I can double boot an other OS without writing anything in the headers of the main system drive.


As former long time Mac user, it's pleasant to run Mac OS without having to buy their so sexy designed machines but always stingy hardware (crippled GPU, skimpy built in RAM and expensive upgrade etc.) and questionable reliability. Not being ungratefull, maybe I'll by a Leo DVD but never will I give a penny in Apple hardware again, preferring to choose my components.





When I get hardware properties in my Win XP 32 SP2, I see the network adapter is called Realtek RTL8169/8110. Somehow the network chip would work so far so good. For me, Kalyway's 8169 kernel extension was OK.

I used a real old 300 MHz Celeron rig with Windows 98 to get answers to problems, getting my mails, going on loading some things so, while being testing, installing the mac things; after I had to transfer data between Win 98 and Leo (by LAN via a Linksys router), testing with 700+ MB files and all was OK. No quenel^W kernel panic.



HDD controllers:

The IDE controller's plug is empty, no drive on it.


Kalyway booted on AHCI SATA ODD, installed the EFI-MBR things (with Vanilla options checked later) on the target AHCI SATA HDD formatted MBR so that a second FAT32 partition could be used as gateway between Win XP NTFS (without having to mess Windows with MacDrive or so). It was OK out of the box.


To give you an idea, the Xxx 10.4.11 DVD could only boot in my SATA ODD set as IDE and/but accepted to install the OS on a IDE controlled drive, installing the AHCI pack so that the drive would run later on AHCI. I can boot whether Win XP or Mac OS without having to switch IDE > AHCI and AHCI > IDE. Otherwise, the foreign OS get to /dev/null (thou the nice hard work from all the crews, no offense to you, I'am maniac :tomato: ).


As you can read it in the HCL topic, the only hard work was getting sound using AppleHDA Patcher 1.20.




The only parameter optionI dont have (probably depending on the CPU used on the mobo is the Virtualisation line, maybe because the E2140 doesn't manage it? I don't remember having to modify something about that.


CPU Feature:

Thermal Control - Enabled

Limit CPUID Value - Disabled

C1E Function - Disabled

Execute Disable Bit - Enabled

Virtualization Technology - Disabled

EIST Function - Enabled


EDIT: By the way, my E2140 is shown as 2,8 MHz Intel Core 2 Duo, 2 GB 800 MHz RAM.

It's bizarre that your Q6600 (G0 or older) is not displayed as Core 2 Quad or so.

Have you searched if other Q6600 owner are having such problem?




Regarding the Beta BIOS I use, this v.1.0.1 mobo ran with the shipped BIOS (11 or 12 ?) a few days but I had some weird things with uGuru GUI software, found no information about my problem, so decided to try out the beta BIOS (available here), thou there's no feature list provided.


I didn't notice bad or good side effects on Windows, beside the bad uGuru reading/reporting CPU temps was fixed.


I can't tell you if an other BIOS could fix your hackintosh, Kalyway was installed and run as describded in 10.5.1 HCL topic with V1.6 Beta 04




Does your rig run gently with Windows? Is this rig well cooled, no overheat?

I read that the PWM/mosfet cooler is sometimes misplaced, with less than necessary contact between the chips and the cooler sole => the thermal compound be quite not marked by the chips. It always get pretty warm, not hot... maybe yours remain too cool.

Do you have a good power supply to feed all that?


If any, check Abit-USA forum to see if people have problem like yours.

Edited by Zoot Allures
Link to comment
Share on other sites

My Q6600 is a G0 stepping, and I thought it was odd that it didnt report correctly too. I've done about 5 installs now of Kalyway on this setup, and it seems like the first one showed up correctly, but subsequent installs report "unknown". I have upgrade the BIOS just now to the latest beta, and noticed the BIOS reporting of the CPU to be different on boot up, so maybe a clean install again will make things better.


I also notice now that my CPU fan speeds up and slows down inside OSX, depending on the load I create. Before on the original BIOS, the fan was constant.


I also havent installed any other OS on this rig yet. I guess I should try that, and make sure there isnt something wrong with the mobo or cpu (windows xp with a few days of prime95 testing should let me know). Also, another OS install with some large data transfers will help diagnose the issue I would think.


I did manage to use the AppleHDA patcher with good success, although my speakers are Logitech Z-10 USB speakers so the onboard sound goes un-used. But the ports (in and out) did show up after the patching in the System Profiler (or maybe it was inside Skype app that uses audio in/out).


My mobo is revision V1.1, and runs very cool. I have 3x120mm input fans plus a 250mm input fan on the case side, and all output air vents are cool, even PSU output is cool. PSU is hefty, Enermax 620W. One thing that wasnt very clear in the owners manual for the mobo, was the additional power connector (molex style) next to the PCIexpress slot. Did you attach a connector there or not?


Right now I am grabbing iATKOS DVD, and once that completes, I will install Ubuntu Linux to see how that does, and then try XP or Vista. Hopefully I will figure something out soon, if not I might RMA return this mobo and just live with my Asus P5B deluxe (assuming that it can run my Q6600) or get an Intel Bad Axe 2 mobo.


One other thing, I grabbed Temperature Monitor, and it reports all 4 of my cores running at 33C +/- half a degree. When I click on one of the core temps, the detailed popup identifies the cpu as "Intel® Core2 Quad CPU Q6600 @", so that program is able to correctly ID the cpu.

Link to comment
Share on other sites

OK, that's good news. Other BIOS and your G0 is seen as it does. Quite surprising that a recent batch (your v.1.1) is unable to identify a by now quite old CPU. The G0 was on the the market in october when I bought mine (no idea if mine could deal out of the box with a Q6600).


On another hand, you CPU cooler control is now better.

It seems that Bresinks Hardware Monitor can identify the real TJunction value for my M0 E21x0 and a give a feedback on my rig, keeping the CPU fan at lower speed possible, it is +/= 40°C with a basic load, a bit hotter by the same use than in Windows.


You should have try Windows at first to ensure if all your new hardware is working well, for a soon RMA matter and to be sure when using something a bit "special" like OSX86, should you? :)



I tried Uphuck's iAtkos, unsuccessfully... whatever the settings, even installing manually the EFI on the partition (they provide a script in the Utilities menu of the CD to do that). No dice... You tell us if you have better result with it.

Link to comment
Share on other sites

Well this is interesting. I swapped out video cards and ram from my Asus setup, and re-installed after the BIOS update, and setting drives to AHCI. One of those settings/changes has created a stable system!


So now I am wondering if there was something wrong with my new G.Skill ram (that tested good with memtest) or my 8800GTS card. I know I had previously tried AHCI, and had crashes, and the install I had done after the BIOS upgrade still would crash when not in safe mode.


So that points to the RAM or Video card. Guess I can shutdown and swap the ram back in and see if it crashes still.


I suppose its possible the video card was overheating somehow, causing the freezes (maybe a power saving blank out timeout causing an issue?) but I would have thought the crashes would continue in safe mode if it was the video card, since the most recent install under the 8800GTS card did not have any video drivers selected in the install, or any applied after the install.


This install still reports my CPU as unknown though, but I saw where I can mod some files to fix that. At least I seem to be making some progress!

Link to comment
Share on other sites

Well there are exactly 3 things I have not put back into the system, and yet everything is 100% stable. First thing is a powered USB hub, which I would have a very hard time believing that it would cause kernel panics. The other item is the nvidia 8800GTS card. At this point, I'm not going to worry about swapping it back in, in place of my 8600GTS (its better for video playback anyway). The last thing not on the system is my Logitech Z-15 USB keyboard. I am currently using a Dell USB keyboard. Again, given that the keyboard was recognized before, showed up in the device list, I cant imagine it was the source of any problems.


So that begs the question, could a video card really go bad in such a way that it would work mostly, but cause random panics/hangs? Or could it have been more of a conflict between the card and another device (mobo, ram, cpu, etc).

Link to comment
Share on other sites

On another hand, you CPU cooler control is now better.

It seems that Bresinks Hardware Monitor can identify the real TJunction value for my M0 E21x0 and a give a feedback on my rig, keeping the CPU fan at lower speed possible, it is +/= 40°C with a basic load, a bit hotter by the same use than in Windows.


And from your sig:

cpu: Intel Pentium E2140 @2880 MHz 2,8 MHz Intel Core 2 Duo, Bus speed 1400 MHz, cores temperatures ≈43/45°C


I'm seeing constant temps in the low 30's on my CPU. But I am noticing some very irritating fan noise fluctuations. I cant be certain its the cpu fan or gpu fan without opening the case up again (I plan to do that tonight). But I am curious how you have your uguru stuff in bios setup. If I recall (and I didnt spend much time in the uguru section) there is fan control in there for the cpu. I am wondering if I am temps set wrong somewhere causing the slightest increase in load (i.e. moving the mouse) to increase the fan speed. If my CPU's cores are running under 35C, I see no need for massive fan speed. On my old AMD rig, the cpu (X2-3800) ran below 30C and most of the time the fan would just turn off!


Anyway, if you can give me an idea as to how you setup your fan controls on the cpu I would appreciate it! Everything else seems to be working great!!! :D

Link to comment
Share on other sites


  • Create New...