Jump to content

Last chance for Leopard. It's too much


3 posts in this topic

Recommended Posts



For a long time I wanted to install this development miracle on my PC. I've considered buying Mac, but unfortunately, for the price of MacMini, I can have machine simply as powerfull as Mac G5... so... you know... xP


For a new year I decided to change something in my life, so I thought Osx86 would be good choice.

Firstly, I've downloaded flat image (unziped ocuupies more than 16 Gb) of Osx86 Leopard and - going by many guids, tutorials, posts I end on nothing. What I have right now is:


I prepared a fresh partition (unformated) in Vista manager (20 Gb).

Next I put image of Leopard on this partition by script:


dd if=leopard-x86-flat-img of=\\?\Device\Harddisk0\Partition2 bs=32256 skip=1 --progress


I found some alternative for chain0 on some Brazilian forum - tboot. Becouse I'm on Vista I don't have ntldr file. So XP install CD > copy > paste in root windows folder. In root folder I put two more files: tboot and made by myself boot.ini:


[boot loader]

[operating systems]

c:\tboot="Mac OSX Leopard"
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows Vista" /fastdetect


... reboot and... Hmm.. No HFS+ partition found. This problem took me some time, but I've found a mistake - Leopard partition didn't have a id. So I booted windows and in few steps in diskpart tool I set ID to af.


Ok.. It should've work then... By the restart I've selected Leopard from Vista boot menu and... For @#$%! Apple logo's sake... for a one second xP. I'm standing here right now. I have no idea what else I could do. I've tried to use vebouse mode by hold F8 key and paste in Darwin -v - doesn't work ;/ - still Leopard is trying to run something and reset on Apple logo. -s doesn't work too.


I have no idea how could I read error code.


Please! Please! help me... for new year... for my life with Mac OS!!! xP






No Tiger, no osx86 install cd (only flat image)

Asus P5B motherboard

C2D 6600

GF 8800 GTS

TV Tuner WinFast 2000XP (any chance to work on mac os?)

Vista and many LiveCD linux

Link to comment
Share on other sites

Jaffe - realy? It's good information for me - 33% download of iATKOS :P


20 minutes ago I've tried to repair SATA fake. Maybe I'm blind, but it seems that I haven't AHCI support in my BIOS (Asus P5B mainboard). So I decided to copy AppleAHCIPort.kext and AppleVIAATA.kext from Tiger to Leopard extensions folder (I haven't Tiger - I found this files in the Internet :) ). Unfortunatly there was a litle problem - I'm working on Vista 64 bit system, so I have no support for MacDrive. :(

I've tried to run it from Windows XP x86 Live CD (BartPE), but there is no way to run this program without installing it (btw. there was very litle chance to fire it up on this system - live windows has almost nothing - no important dll's and applications)


Next whate I've try to do, was thesame what on Win Live, but more advisable platfor :P Knoppix Linux Live.

By almost two hours I've tried to run HFS+ support on this #$%^&! system, and well... I've tried to use a mount command, but in result I had a read-only access. I've readed, that to make writable this partition on Linux, I mut tu install new software - hplibs, or something like that (realy I've had nystagmus, when I do this - a hundred of names starts for "hs" :| When I found this ONE program, that, make me able to mount HFS+ partition (hpmount), and use it in right way (hpmount /dev/sda2 /OSX86) He tels me that there is no HFS+ partition in my system ! God !!

I've tried to mount HFS+ by "mount" in reed-only and.. surprise, surprise! code page error!


In result of all magic, that I does now I have faked partition with Leopard. There is no way to repair it by setting ID, or something like that. When I'm trying to boot from this partition by tboot I see only blinking coursor.


So... If there is a chance, that my error posted upper comes from SATA support, I'll try again from the beginning, and I hope that on fresh install on osx86, and without a tousend of operations on linux I'll be able to use hpmount and I'll copy AppleAHCIPort.kext and AppleVIAATA.kext to extensions Leopard folder.


Anybody can give me a respond?





P.S. I didn't say that in first post, but english isn't my family language :P so please be tolerant reading my scribbles.

Link to comment
Share on other sites


  • Create New...