Jump to content

IDE DVD drive and Leopard


4 posts in this topic

Recommended Posts

Good evening :)


Is it possible to use one of my IDE DVD drives to install one of my four versions of OSX (Tiger 10.4.8 JaS, Tiger 10.4.9 Uphuck, Tiger 10.4.10 Kalyway, Leopard ToH) on my Gigabyte GA-P35C-DS3R? I keep getting the Config file missing com.apple.boot.plist error, and I've been searching for a long, long time. A solution seems to be using the Brazilmac patch, but I don't have access to my mac to use it, I only have a pc to patch anything. Brazilmac's patch doesn't work in Windows I'm afraid. So, is there any other way to install OSX86 using my IDE DVD drive, or do I have to buy a SATA DVD drive?

Link to comment
Share on other sites

You can use the flat image (MBR) and try that out. I did it with no issues. Here is a quick run down of what i did...


-Installed all of the hardware into my case (DS3R, E6750 proc, memory, etc w/ IDE DVD drive)

-Installed XP (32-bit)

-Brought up XP and downloaded the flat-image from usenet

-Removed all partitions from the 160GB that I wanted to install Leopard on

-Created a 15GB Partition (no formatting or mounting in XP), then created another partition with the remainder of the disk

-Went into My Computer - Properties - Device Manager - (right click on NIC) Properties, set to Wake On LAN - YES

-Ran the flat-image install

-Rebooted into OSX (left the LAN unplugged until the Setup was done)

-Followed the Instructions for EFI v51 (excepting for a few typos they have in there) and copied over the vanilla kernel

-Rebooted into Single-user (per their instructions)

-Booted back into the OS and used DiskUtility to format that extra partition as HFS+ (journaled)

-Used the command line method to grow my current partition to the entire disk

-Copied over ALCInject and AppleHDA, chmod then chown those, then use kextload -t from the command line to test them

-Reboot the machine

-Sound works at this point, my 7300GT worked with whatever they have loaded in the flat-image

-Updated to 10.5.1 and installed all of my software

Link to comment
Share on other sites

Thanks guys, I'm following obajoba's steps as we speak. If it doesn't work I'll fetch an adapter. I'll keep you posted on my progress.


Update: I've succeeded in getting the flat image on my second HD. I've removed my primary HD to be able to boot Darwin, however:


Error parsing plist fileLoading Darwin/x86


I've tried -x -v, but after a small flash of text the same error pops up. Is there a BIOS setting I should change?

Link to comment
Share on other sites


  • Create New...