Jump to content

Kernel Panic When Booting OSX (but only after booting XP)

3 posts in this topic

Recommended Posts

I also posted this in the main troubleshooting thread, but haven't gotten any responses. Please let me know if this has been discussed before, and this is why it's being ignored...I'm just at a complete loss here, and have searched with no results.



I've setup the Dual Boot by modifying the boot.ini file to include the c:\chain0 line. I've also copied the chain0 file over from the OSX install DVD I used.


Upon first boot, this process worked perfectly. I selected OSX and I was in. I then rebooted, and tried selecting XP, it also worked!


Upon rebooting again, and selecting OSX I am presented with a kernel panic. It refuses to boot OSX after it has just booted XP. After unplugging the hard drive that has XP installed on it, and setting the primary drive to my OSX drive, OSX boots without a problem.


I did some more testing, and even plugged the XP drive back in. Set it as the default again, and tried booting OSX. It again worked fine, but only because I hadn't yet booted XP.


Long story short, upon booting XP it seems as though it is writing something somewhere that messes up OSX on it's next boot.


I've searched these forums, but it doesn't seem like anyone has had this specific problem. I've read about the Darwin menu not showing up, and being stuck in a loop after booting XP, but this isn't the case here. I also read about XP rewriting the MBR, but isn't this only a problem if the operating systems are on the same physical disk?


Both hard drives are Serial ATA. In addition to the two for each operating system I have a third Serial ATA drive for storage, HFS formated.


I appreciate any and all help, this is giving me quite the headache. And as much as I love opening up my case and unplugging hard drives, there has to be a fix!


My system info is below.

Link to comment
Share on other sites

Hi Jhoule:


From reading your post, it looks like something may be still be in Memory with "warm" reboot as opposed to "cold' reboot (by shutting the machine down).


I have not experienced this issue personally since I'm using running one (1) internal IDE Drive with two partitions (Mac OS Extended and FAT32 for Windows) on all my machines.


--danyel :)

Link to comment
Share on other sites


  • Create New...