Jump to content

[ SOLVED ] display problems...resolution and refresh rate can't be changed


8 posts in this topic

Recommended Posts

i can't change the resolution (only option: 1024x768) and refresh rate says "n/a" ---> reeeaaallleeey strange, because when connecting my display to my macbook i get loads of choices in both categories...help anyone?>>sysprof for graphics card and display:post-158441-1196565061_thumb.jpg


i just saw, apple sells this card in an "apple" version, i have the original nvidia version of the 7300GT, but i can't find any mac drivers, am i missing something?

>>http://store.apple.com/1-800-MY-APPLE/WebO...rnMore=MA567Z/A ^^

Link to comment
Share on other sites

NVinject is loaded, but maybe other NVidia kexts are not.


Unless you see Quartz Extreme: Supported on System Profiler you can't change your resolution.


yes, i deleted NVDAResman.kext, NVDANV50Hal, 40HAl and so on - not having them deleted would give me bluescreen and waiting and waiting but no login screen coming up -- think mainly resman, cause until resman is back eveything is just like before...




even worse, off verbose mode it gives "please restart" screen and in verbose last thing it says is "error referencing IODeviceTree" -- this is really driving me nuts, on a spare disk i run tiger 10.4.8 and have no problems with my graphics card what so ever, it even shows the name of my display and all... weird stuff...


-- > macgirl, please note, in tiger it also says quarts extreme not supported, but my graphics card works like it was a real mac, so that's not the error...

Link to comment
Share on other sites

i made it wrk, FINALLY!!! the key was, leopard can't deal with NVinject -> you have to enter your pci id (or wotsoever) yourself, your id goes like this:


0x (last 4 digits of device id - in my case 02e2) (last 4 digits of vendor id - in my case 10de)

>> 0x02e210de


now take this string and put it in your NV*** files, plus in the GeForce.kext --> but don't you dare messing with the NVInject, leave that as is and you'll be fine, just change all the files that came with the installation.


for those of you, having no idea what i mean -> open the kext go to info.plist > open with TextEdit and look for PCI ID Primary something, and replace the text between the <string> thingies, when you get there you know what i mean.


done that, chown all the files to -R root:wheel and chmod them to 775 -> and there you go, perfect install


>>>>> i have an original nVidia 7300GT, latest revision, and used NVInject 0.1.3 leo only on that.


took me 2 days to work it out, but finally i'm up and running, next thing is figuring out why network won't work... it's in the devicetree and even right mac address, it eeeven blinks when trying to contact my router, but it won't get a dhcp address, any suggestions?


--> also solved, had to download intel kexts


now one problem left, in leopard i can't completely shutdown or restart, well i can by it won't power down the system or "hit the restart button" - any suggestions?

Link to comment
Share on other sites


  • Create New...