Jump to content

Strange iPhone unlock issue


13 posts in this topic

Recommended Posts

I seem to get all the strange problems with my Apple stuff.


So I was running 1.1.1 unlocked and everything, I saw that SIMfree were offering a way to upgrade to 1.1.2 and stay unlocked. I though I may as well. So I tried and failed. When I went to jailbreak my phone after I had upgraded to 1.1.2 it says I had to install oktoprep while I was in 1.1.1. Well I had done! So what the problem was I cant quite work out. So I downgraded to 1.1.1 successfully and the jailbreakme.com site worked fine.


Only one problem, I now don't get anything from my SIM thats in my iPhone. I doesn't say "SIM not supported" it just wont give me a signal. I tried with other SIMs and the same thing happened. I downloaded anysim 1.8 and it claimed that my phone was already unlocked. Anyone have any idea whats up with this?



Link to comment
Share on other sites

Umm your baseband firmware is 4.02.x.x



This is what you need to do

1) Get the Baseband Downgrade Pack from here

2) Extract and send all the files to your phones /usr/bin using CyberDuck or something similar

3) ssh into your phone using Terminal

4) Type in the following into your phone

-"launchctl remove com.apple.CommCenter"

-cd /usr/bin

-chmod 755 *

-bbupdater -v


It should show that your firmware version is 4.0.2


Now more typing into phone



-bbupdater -v


It should now say baseband unresponsive. Now lets get a working firmware back.


-bbupdater -e ICE03.14.08_G.eep -f ICE03.14.08_G.fls

-bbupdater -v


Now it should say Radio firmware is 3.14.08




Follow this guide to Virginize your baseband. (Just incase)

Now do a restore with the 1.1.1 software and unlock 1.1.1 normally.

Link to comment
Share on other sites

The method I posted above will downgrade your Baseband, not your software. Also try restarting, it seems to help, when you iPhone is weirding out.

Link to comment
Share on other sites

ok. if I may.


I have the very same problem as You - MyPancakePlaces

Just yesterday i have 1.1.1 unlocked-jailbreaked-SIMFree iPhone. And...


I saw big article about upgrading to 1.1.2 - and working - still unlocked, etc.


I checked every point of attached manual. Download the proper software. And step-by-step try to fix it out.




Almost at the end. I need to run Oktoprep - it hangs. I mean the application and the iPhone.


It just STOP. OK.


So i rebooted the device... And from now on - all it starts....


Now.. when I Restore... (in iTunes) almost every 1.1.1 software that I have (I have 3 of them - from different sources...), after iPhone reboot - I got the standard startup screen where Activate in iTunes dialog appears. And there is a slide button to switch to Emergency Call Mode. It works... but anything else - NO



When I try to dial ANY number, the keyboard is terribly delaying (lag) - i see what i type after 10-15 seconds.


At the Main Screen (Welcome Page) I see BIG: Activate iPhone - connect to iTunes - with little "i" mark switching to IMEI preview... And beneath is Pop-up Window:


Repair Needed - Iphone cannot make or receive calls. - www.apple.com/support/


And that's all...




ANYBODY... Can someone please help me... :D Please... I'm wasted... :D Please have mercy.. ;)


Can I install 1.1.1 and unlock it again...? Because I understand that I have Modem Firmware (baseband) 04.02.13_G - after trying to install 1.1.2 ???


Or I have the 04.02.13_G when i'm using 1.1.1 unlocked too....?


Or.. :) how to change modem firmware version (04.02.13_G) without Wi-Fi Connection? :)

Link to comment
Share on other sites


  • Create New...