Jump to content

"Still waiting for root device errors", No ethernet, updating, Please read this!


2 posts in this topic

Recommended Posts

Hi everyone, I'd just like to say that this is my first post here at InsanelyMac and so far I've found the forums very helpful. However, this is probably also going to be my last post, since I've abandoned my OSx86 struggles. Though if this helps anyone, even by 0.1%, I'll feel that my time wasn't totally wasted.


First off, I actually did get 10.4.4 to run on my PC, a Sony VAIO PCV-RX830 (SSE2, SiS 651 chipset). This seemed to be the only version that worked for me; all the Jas, uphuck, Kalyway, XxX, etc. couldn't install. If you are having any kind of "still waiting for root device" errors, the best thing you can do is install via VMware. Ok, so you've gotten that far, but can't get it to boot up natively. What I did was I have two separate HDs (best way to do it, although you can follow dual boot instructions as well), and I installed OSX on one HD (4.07 GB), and then copied that drive using Norton Ghost onto an external USB drive and set it active. Then I booted up, selecting my 4 GB HD, and plugged in my USB drive. When it gets to the point where it can no longer read the PATA (or SATA) drive, it should automatically start reading from your USB drive. Voila, OSx86 native on your machine. One note though: be sure to finish the actual setup (create your account) in VMware, and then copy the drive to your USB drive. Otherwise, it will not boot.



As for ethernet, in case anyone hasn't seen this yet, this is the best if you have 8.4.1 (only one I was able to use) or 8.8.1.




I took the risk taker's approach, and it worked like a charm. Obviously your mileage may vary, but it's worth a try.



Finally, as for updating, if you can get it to work, you're awesome! If not, well there's always tomorrow, and Google. The best thing I found was to use Norton Ghost, create a recovery point just after installation, and then whenever I screwed up I just restored and started over.



Anyways, I know a lot of this was already here on the forums, but I just wanted to write something that put some of the stuff I found useful here together. Hopefully it helps someone. As for me, well I just deleted all traces of OSx86 from my computer just now, and I hope I won't mess with it again anytime soon. Would've liked to have FCP, but I guess you get what you pay for... :) Anyways, please tell me if any of this helped you, and if it doesn't work, take a break and have a cookie.

Link to comment
Share on other sites

  • 8 months later...

  • Create New...