Jump to content

VMware + ethernet NVidia NForce + Mac OS 10.4.8

6 posts in this topic

Recommended Posts

Hi all,


Thanks a lot for this great forum. So here's "my" problem. :D


I've installed Mac OSx 10.4.8 (with the JaS Mac OS X 10.4.8 Intel/AMD SSE2 SSE3 PPF1+PPF2 iso) on VMware 6.0.0 build 45731, on Windows Vista. Ok everything is allright except the ethernet connection ! My motherboard chipset is nVidia nForce 650i SLI. The ethernet cable is plugged behind a dhcp router.


I've try everythings to make it works :

- e1000 line in VMX configuration file

- Maxxuss AMDPCNET Driver

- Command Line IP Address Renewal

- this method (post #7)

- changing my mac address (which is still 00:00:00:00:00:00) with many command lines


- and I read every posts/topics I can in this website.



So if someone knows anything or has an idea, it will be very nice ! :D



PS : Please excuse my english, Im french !!! :)


Link to comment
Share on other sites

I've just logged on to ask about EXACTLY the same thing!! I've used the same disc, inside VMWare server (1.0.3 and 1.0.4) and got everything installed - all is well.


I've done all the above, tried claiming to be darwin, FreeBSD, winnt, etc. nothing seems to get the MAC address to hold.


I'm using an AMD laptop, but I've a feeling (given the number of people experiencing this problem) that the underlying hardware may not be the problem so much as the interaction of VWware with OSX.


I'll keep trying, but any other ideas would be most welcome ;)



Link to comment
Share on other sites

further to this, I was wondering about whether editting NetworkInterfaces.plist directly could help? Does anyone have any advice about that?


Mine currently lists as

<key>BSD Name</key>


would altering the IOMACAddress alter anything - and if so what should it be? I've seen all sorts of values around, but wouldn't like to hazard a guess as how to calculate it!



Link to comment
Share on other sites

I've got the exact same issue.

I used the JaS Mac OS X 10.4.8 Intel/AMD SSE2 SSE3 PPF1+PPF2 ISO on Vmware Server 1.0.4, and I can't get internet.


The system will recognize the connection, but putting Vmware's ethernet settings to Bridged makes my internet stop working in Windows XP, with no change in OS X except the IP that it binds to.


I've got the nForce 570 SLI chipset on my motherboard, so that may have something to do with it. Haven't been able to find any solid information, though, besides the fact that the forcedeth.kext driver patch does not work for me.




OK, I fixed it.


I found out that all I had to do was remove the e1000 line from the config file and set the VM network mode to NAT.

Link to comment
Share on other sites


  • Create New...