Jump to content

Problem with dd for windows


1 post in this topic

Recommended Posts

Hello, I am using the install onto a partition using dd method to install osx86 but have run into a bit of a problem. I have one harddrive which is split into two disks (volumes?). The first part of the harddisk is c which i don't want to touch. The C drive(not sure if it's a drive or volume if it's on the same harddisk) is only 20gb and contains windows and other files which i don't want to get rid of. However the other part of the disk (the E drive/volume/partition) is completely expendable although i would like to still use this partition to store files from windows (It's about 60gigs). I backed up the files previously on E and deleted the partition, then used disk management to make this one smaller to make room for an osx partition. I have successfully partitioned the remainder of the drive to the AF type and it should be ready to have the tiger-x86-flat image copied over right?


Well, when i do use the dd --list command i get quite confused as to which partition to copy tiger onto,

C:\tiger-x86>dd --list
rawwrite dd for windows version 0.3.
Written by John Newbigin <[email protected]>
This program is covered by the GPL.  See copying.txt for
Win32 Available Volume Information
 link to \\?\Device\HarddiskVolume1
 fixed media
 Mounted on c:\

 link to \\?\Device\HarddiskVolume2
 fixed media
 Mounted on e:\

 link to \\?\Device\CdRom0
 Mounted on f:\

 link to \\?\Device\CdRom1
 Mounted on d:\

 link to \\?\Device\Floppy0
 removeable media
 Mounted on a:\

 link to \\?\Device\Harddisk2\DP(1)0-0+6
 removeable media
 Mounted on g:\

NT Block Device Objects
 link to \\?\Device\Harddisk0\DR0
 Fixed hard disk media. Block size = 512
 link to \\?\Device\HarddiskVolume1
 link to \\?\Device\Harddisk1\DR1
 Fixed hard disk media. Block size = 512
 link to \\?\Device\HarddiskVolume2
 link to \\?\Device\HarddiskVolume5
 Fixed hard disk media. Block size = 512
 link to \\?\Device\Harddisk2\DR5
 link to \\?\Device\Harddisk2\DP(1)0-0+6

that's what i get when i dd --list. i've tried setting of to where i think the partition is located (harddisk1\partition2) but it hasn't worked. I waited until it was finished and checked the partition through the disk manager to see that the partition was still empty, wasting an hour of valuable osx86 time :P so am I trying to write to the wrong partition?

Thanks in advance for your time.

Link to comment
Share on other sites


  • Create New...