Jump to content

Install Success: Mac.Nub 10.4.10 on Dell E1705/9400


2 posts in this topic

Recommended Posts

To help out posterity (since noone helped me despite asking for help), I thought I'd post a quick report of my near complete success.


Install Used: MacDotNub OSX86 10.4.10 v1r5. Though I can't say where to get it, there's a cool website named mac4share (you can guess the extension) that lists some rapidshare links. Mac.Nub, you've made a killer install and far more complete than the others I've seen.


Non-Working: Only my wireless card and the subwoofer. Video, ethernet card, DVD drive, all work flawlessly.


Dell E1705 Specs:

  • Intel Centrino Core Duo T2500 (MMX, SSE, SSE2, SSE3)
  • Dell Motherboard (Model 0YD479) using Intel i945PM r3 Chipset and Intel 82801GHM (ICH7-M/U) Southbridge
  • Bios revision A09
  • Nvidia Geforce 7800 Go (17" UltraSharp WUXGA (1920x1200) TrueLife LCD 1920x1200 resolution)
  • Sigmatel 92XX Major-C HD Audio (not sure how to determine exact chipset, but 9200.txt with AppleHDAPatcher provided typical results, i.e. great sound but no mute upon headphone insert and no subwoofer)
  • Intel 3945ABG Wireless Card
  • Broadcom 440x 10/100 Ethernet Card
  • Windows Vista (activated using OEM Bios emulation.)


  1. Shrunk primary (and sole) HDD by about 16GB as I wanted some extra space to fool around with beyong the usual 6GB recommendation. Did the diskpart commands. Confirmed that there was the 16GB partition.
  2. Rebooted using Install ISO by hitting F12 to set the one-time boot menu to boot from DVD Drive. I quickly realizzed it had no timeout counter, so I did a quick CTRL-ALT-DEL to start over, and this time made sure to MASH the F8 key as it was booting from the DVD. I then ran it with "cpus=1". Ahh, much faster and better - no stutter.
  3. At the install screen, ran Disk Utility from the pulldown menu at the top. Selected the 16gb partition (named rsdisk0 or something of that sort). Selected erase, with Mac OS Extended (journaled) as the format. Went quick. Exited disk utility
  4. Back at the installer window, selected with the following:

      1. Base Files
      2. 8.10.1 kernel (didn't bother to mess around with the 8.9.1 kernel mix and match)
      3. SATA support, though I'm pretty sure this is supported anyway.
      4. NVinjectGo video driver (for my mobile Geforce Go card)
      5. Standard (and already selected) ethernet card driver for my Broadcom
      6. I Selected no wireless driver, since, as I understand, none work for my card
      7. The other odds and ends that don't really matter (and I can't remember)

[*]Skipped check of my disk (too excited to wait), and let it install.

[*]Upon Restart it WOULDN'T BOOT! So I rebooted off of the Install disk, mashed F8 to get "boot:" prompt and ran "-s". At prompt that comes up after going through its whatever, I did what Devilhood recommends in his tutorial to make the osx partition boot (though read Step #11 which may save you the hassle that appears in Step #9):

  1. [*]After doing this, it booted to the OSX partition. Booted fine. All worked perfectly except sound.

    [*]So that I wouldn't have the issue of hammering the F8 key to get a prompt on the next reboot, I ran Terminal (in your Applications/Utilities folder) and edited com.apple.Boot.plist as follows:

    1. [*]I then rebooted, and saw the Darwin Bootloader screen with an 8 second countdown. I selected the NTFS partition to load Vista. UH OH! Corrupted! No problem, I just followed the instructions on the screen, which involved inserting the Vista installation disk and repairing.

      [*]After that reboot, it boots to Vista meaning that everything I did in Step 6 above was undone. So I then pulled out the disk and inserted the OSX install disk, and rebooted.

      [*]Rebooted to the Installation disk, mashed F8 (remember, the timeout is set on the HDD OSX partition, not the Install DVD!). Ran it with "-s". At the prompt I did exactly as I did in #6 above, BUT after typing "flag disk 2" and hitting enter, I just type "quit", hit enter, and then typed "reboot" and hit enter. In retrospect, I think by typing the "Update" and "Write" commands, I rewrote the Master Boot Record in a way that f*cks up the bootability of the NTFS partion. So you might want to skip the "update" and "write" commands in your installation process and consequently won't have to deal with steps 9, 10, and this 11.

      So as I now have it, I am using Darwin's bootloader, adjusted for a 8 second timeout and set to run with cpus=1 to stop stuttering. No matter what I try, I can't get Vista Bootloader to work, but I suspect it is due to the fact that my Vista is a pirated copy making use of Motherboard OEM Bios emulation to stay activated.


      Hope this helps everyone.



      1. How do I properly install tbcarey's kexts and all that to get my subwoofer working?
      2. Is there a driver for the Intel wireless card I have? I really would like to have wireless working.



      1. I have MacDrive 7 running on Vista in order to access my HFS (Mac OS drive). It has had the wierd effect of making all my files, when running mac os, show their extensions regardless of whether they've been selected to be hidden. Its a tad ugly, but whatever. OSx has a pathetic implementation of hiding extensions anyway.
      2. Stuffit Expander causes problems with mounting .DMG files. After I uninstalled that program, mounting resumed normally. UnRarx is a {censored} program, which cannot handle passworded .Rar files properly. I simply use winRar in Vista and then copy over the decompressed file(s) to my os partition (MacDrive 7 is very useful!)
      3. After messing around with OSX, I am certain I'd NEVER buy a Macintosh. Its fun to play with, but I'd never run OSX as my main OS, and that's WITH having a right-click button. I couldn't fathom not having at least that! I don't get the appeal. But to each his own, I guess.

  2. I typed "sudo nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist" in the terminal window (without quotes. It asked for my password, this is the one you set OSX up with.
  3. I added the following:
    <string>8</string> <key>
  4. I also added the following:
    <key>Kernel Flags</key> <-- This was already there
    <string>cpus=1</string> <-- This was alread there too. I just added the "cpus=1"
  5. I pressed CTRL+O and then Enter to save the file and then CTRL+X to exit.

"fdisk -e /dev/rdisk0"
"flag 2" (this is because your osx partition will invariably be the second partition. Vista's is 1)
Link to comment
Share on other sites


  • Create New...