Jump to content

Attempting install of OSX on Abit AB9 Pro


7 posts in this topic

Recommended Posts

I'm an OSX86 n00b. There. I said it! Although I do love me some FreeBSD :D


I've got an AB9 Pro as follows:

Core 2 Duo E6400 2.13Ghz

320 GB SATA HDD (Maxtor)

IDE DVDRW (Sony) (currently plugged into the PATA port)

SATA DVDRW (Samsung) just bought this in the hopes it would help

Nvidia GeForce 7300GT PCI-express

Windows Vista Ultimate


I also have, for the OSX86 install, an IBM 40GB IDE HDD. This is attached to a Promise ATA133TXX2 card in a PCI slot.


Before describing the problem, here's the anomoly:

- Each of these releases (iso burned on DVD-R and DVD+R)

- The first one I tried was the upchuck release

- In short, when I try the any of the install dvds, if I press F8 on the load screen, the only option is for the upchuck release (I forget the exact text)

- The weird thing is that it doesn't matter what DVD I'm booting from, the entry after pressing F8 on the load screen is ALWAYS the same.

- I tried searching through the BIOS for some kind of cache

- I tried unplugging every drive except the DVD player I'm booting with

- I turned off the system and left it unplugged for a while

- None of this changed the fact that whatever DVD I booted from had the upchuck release as the only available option on the F8 screen.

- Is this a little weird???


So, here's what I've tried with identical results for upchuck 1.3 10.4.9 and 10.4.9 with 10.4.10 update by Kill3r and the mac.nub release of 10.4.10.

- dvd burns fine no probs (I have a copy of each on a -R and a +R).

- w/out adjusting any settings in Bios, I get the plist error

- a little research directed me to connect the ide hdd to the Promise ATA card so that it's not using the JMicron PATA controller

- after reading some other forum posts, I bought an SATA DVD drive and I tried that as well without any change

- this got me a little further to a AppleHDA or something or other (sorry did all this last night and have just been researching since then) but the error was something like that.

- A little more research directed me to disable the audio in the Bios

- This gets me to where I'm stuck

- Now I get the waiting for boot device uuid error and it just hangs and repeats waiting for root device (or something)

- I've tried -v to get some more info but no dice


I've searched all of the forums and the interweb (all the search results point back here ;) ) and I see that people are having success with a similar setup so I'm not sure what little thing I'm missing.


At any rate, I'm trying to get two other releases to see if there's any change. Not sure if there's issues with the ISO's - burned them with Nero 7 on Windows Vista.


Looks like folks have had some success on the AB9 Pro and I'm just looking for my share ;)


Thanks and thanks for helpin' a n00b!



So, I'm going to try and turn off the JMicron controller and just go with the SATA HDD and DVD to see if those will will work. Also downloaded JaS 1.4.8 so gonna try that as well.


I've got the ICH8R SATA emulating IDE via the BIOS and the HDD is on SATA1 as the master and the DVD is on SATA1 as the slave. We'll see if I have any luck!


Any other AB9 Pro users out there???

Link to comment
Share on other sites

Why not go for "osx86 Leopard flat image" from your favorite torrent tracker :)


My JMicron onboard PATA controller works just fine and dandy.


I initially had the boot disk in my IDE Sony DVD drive connected to the PATA controller but all I ever got at boot was the plist error. That's when I popped in the ATA133TX2 card and used the IDE controller on that. It got me past the plist error but that's about it.


I'm just getting into this whole OSX thing, the only Leopard install I've seen (so far) is the BrazilMac install which (correct me if I'm wrong) requires 10.4.* installed first... I'll check out the image you mentioned.




Link to comment
Share on other sites

Ok, the anomolies were odd because: I. Am. A. Frickin'. IDIOT!


Apparently, somehow, on all 6 cds I had (3 DVD-R 3 DVD+R) I had burned the upchuck release which was the first one I downloaded. I now have the correct releases burned after figuring out that little bit of idiocy on my part.


I guess it's true: the problem usually is between the keyboard and chair :)


At any rate, I tried the DVDs on my wife's computer and got the OSX install GUI without any issues.


On my Abit AB9 Pro comp, however, I am unable to get past the "waiting for boot device with UUID blah blah blah" issue.


I've got it set up as follows right now:

SATA HDD on SATA1 as master

SATA Samsung DVD on SATA1 as slave

BIOS set for IDE emulation

All USB devices unplugged

I removed the Ultra133TX2 ATA card

IDE DVD plugged into the Jmicron PATA controller


I'm trying to boot off of the SATA DVD drive.


Still no luck with any of the 3 releases I have.


Anyone got any words of wisdom besides give up :D



Link to comment
Share on other sites

The aforementioned flat disk image IS the BrazilMac patched Leopard, except you don't need ANYTHING except Windows (and you can even do it from a linux boot CD)

You don't really install it, but rather just dump it on an empty disk and boot. At which point you're in Leopard already.


You may have to change a couple of options in the BIOS but nothing impossible.

Link to comment
Share on other sites

  • 8 months later...

got my abit ab9 pro working except for the USB ports :)


Used the Kalyway 10.5.2 and it worked like a charm the first time around.


Thank you to TotallyBonkers for the help with the Belkin Wireless N adapter.

Link to comment
Share on other sites


  • Create New...