Jump to content

[Vaio C1Z] After Installation


5 posts in this topic

Recommended Posts

Hi everybody,


I installed JaS 10.4.8 release on my VAIO two days ago. I will explain the problem I solved and ask some question about problem I still have, I hope you can help :unsure:


My Installation :

I used diskpart under windows to create an (id=af) partition which was used to install OSX in DualBoot.


No problem there. I currently use Smart Fdisk to change active partition to boot (I will use darwin multiboot later).


I selected Intel/Hardware/nvidia driver (natit I think) during the installation.


Corrected Problems :

During boot have to plug the sector unless it freeze (I can used battery after launch). I also have to let the installation DVD into the drive bay unless it tells me "error loading operating system".


When I boot the internal screen turn black after apple logo and switch to exernal VGA display.


Actual Situation :

after all that osx works fine. Sound had to be installed and support for network card isn't available. I found Wifi driver but didn't tested it yet.


I had two questions :

- Is there a way to boot without the Install disc in the bay (Sata drivers?)

- What can I try to use my internal screen which is not detected by OSX (maybe install without Natit?)


Thank in advance

Link to comment
Share on other sites



I'm in the same situation (UpHuck 1.4i R3 on Vaio VGN-FE31Z).


Here's what i noticed about VGA drivers in my case :

- If you install Natit 0.2 or Titan drivers the video signal is sent by the VGA port only.

- If you install OSX without any VGA driver it works just fine (video sent to the internal LCD) but the video quality is really bad

- If you install the Nvidia mobility driver (available on my Uphuck disk) its working but video is in bad quality (as if there were no vga driver installed)



I still have this problem so if you found a way of solving it please tell me. I'll tell you if i found something on my side.



Link to comment
Share on other sites

Hum, that's bad news, I was hopping I would do better without drivers.


I also tried MacVidia 1.0.81 driver but I got a fatal error (gray box in four languages). Some threads speaks about using version 1.0.8 instead but I haven't found it yet.


Do you have the same problem when booting ? (sector + install dvd)


I continue my investigation, and post if I find anything.


Thanks for your help

Link to comment
Share on other sites

I made it !!!! Yesss !


Here is how i did it (my vaio has a Nvidia GeForce Go 7600) :


I went to this site :



Downloaded these files :

- NVinjectGo_0.0.9.zip

- NVinject_permissions.fix.zip


Done that :

Copied the NVinjectGo.kext to the /System/Library/Extension folder

Run the NVinject_permissions.command script

I also had to remove a lot of drivers from the /System/Library/Extension folder

- all the NVDA* files

- all the GeForce* files

- Titan.kext

- Mobility.kext


And restart.


I works !


Now i have to make fine tuning to adjust screen size and to see if its possible to set multiple displays.


You'll found info about tuning here :



Hope it will work for you.


Keep me informed of your progress.





---- EDIT -----

Sorry, i was so enthousiastic that it displays video on the vaio LCD that i went a little to far and a little to fast...


Removing this files was not a good idea :

- all the NVDA* files

- all the GeForce* files


They are needed for the GeForce to work properly.


You'll found more infos on how to install NVinjectGo here :




But guess what, it's known to not work with Vaio FE series.


Hope it will work with your Vaio.


If you found any solution to that problem...


---- /EDIT -----

Link to comment
Share on other sites

Great !


Thank you for the update :P

I hadn't tried that driver before.


But I still have a problem I tried to install it on a Running OSX with Titan/Natit (Install patch) and on OSX without it.

- With patch I can't see the difference.. even when I delete files dans run the command script.

- Without the patch I had on default 1024*768 crappy resolution on the internal LCD. Installing the patch seams to work (recognised in hardware list as NVinject Go 7400) but the display is only on External VGA output.


I'll try to tunes it with your link and keep you updated.


Still I have some questions for you :


- What patch/driver did you install and in what order ?

- Finally you didn't removed any NVDA and GeForce files?

- Is it normal that I don't have any nvidiaEFI.kext ?

- I also only have 4 GeForce*.bundle.





New Info : About the boot with Install DVD I succed to remove that step. I can now boot without having the Install Disc in the bay. That appared after adding <key>Timeout</key><string>8</string> to the com.Apple.Boot.plist file.

Link to comment
Share on other sites


  • Create New...