Jump to content

Atheros WiFi 10.4.10 Networkinterfaces.plist

iMatt B.

4 posts in this topic

Recommended Posts

OK Ive seen this post a few times so I decided to post a topic.


With the release of 10.4.10, or possibly with 10.4.9, the file /library/systemconfiguration/networkinterfaces.plist is no longer there. Instead they are substituted with some *.bundles. The problem is, in the fix for the atheros card, you need to switch the en0 to en1 in that file. Now the weirdest part Is I found the same file under /library/preferences/system configuration/ but after changing it and a reboot, it switched back to en0. I attempted to lock the file and then the os created "networkinterfaces.plist-new" with of course the en back to 0. After this I tried to lock the entire folder and then it just ignored the file altogether. SO, any ideas?




iacer 5100

Turion 64 x2

1 gig ram

Ati Radeon Xpress 1100

OS X 10.4.10

Link to comment
Share on other sites

Same thing here. I have a Toshiba U300-NS1 with Atheros 5006. I try to edit that file and it changes back by itself.


Plus there's missing part in that file. There's only information for the Firewire connection. I compared with my desktop Hackintosh and there's 2 another parts missing. One for Ethernet and one for Wifi. I'd like to complete the file but I'm missing the IOMACaddress and IOPathMatch parts.


I also tried a lot of the other solutions in the forums but none are working. I have XxX OS x86 10.4.10 installed.


Any help would be appreciated.

Link to comment
Share on other sites

Ok, the solution to this problem was a bit less complicated than it thought it was. Using the networkinterfaces.plist in the latter folder mentioned, I did not change the <integer>1</integer> to 1, just the en1. After I did that it worked beautifully.


<key>BSD Name</key>

















Link to comment
Share on other sites


  • Create New...