Jump to content

Can't find any command


4 posts in this topic

Recommended Posts



i tried searching but didn't found any answer to my problem.


I recently added the "/usr/X11R6/bin/X" to the path in that profile file under "/etc/"

to get xinit started.


That worked but after a reboot i lost the access to any commands

and can't undo the editings of that profile file because it doesn't let me open PICO through

the prompt complaining that it can't find any command.


An echo $PATH prints out the /usr/X11R6/bin/X path.


What can i do to regain access to the commands. Should be more simple than reinstall, right ?



Link to comment
Share on other sites

Hi Phil,


You've either made a syntax error or completly deleted the path to other commands..


Try this...


- Open Terminal

sudo -s


/usr/bin/nano /etc/profile


(My PATH line looks like this)



ctrl x


(leave filename as profile)





if that works fine and you want to add the additional search path try this:



Hope it works!

Link to comment
Share on other sites

No lollett,


it just keeps complaining that it can't find any commands. the -cd command is working but the -ls is not for example. I just need to get to open that PICO editor again to set the default paths.





Edit: Ok, just did a reinstall, was actually quite fast.

Link to comment
Share on other sites

Hi again Phil...


Did you actuall try what I suggested above???


The fact your echo $PATH statment only showed /usr/X11R6/bin/X means the shell wasn't looking in other folders for commands your looking for such is ls,pico/nano etc!


the ls command is located in /bin so without the path you would have had to type



simular pico is located in /usr/bin so you'd have had to type /usr/bin/pico


the cd command is built into the shell so it doesn't need a path to run it.

Link to comment
Share on other sites


  • Create New...