Jump to content

Apple Pro App Support 4.0.2 won't install. Help apreciated! ;)


7 posts in this topic

Recommended Posts

Hi guys, this is my first post (i think), but i've been passively on this forum for a while now and if anyone can shed some light on my situation it'll be here. :(


So, the problem at hand:


In my house we have 1 Laptop -Toshiba- (Intel SSE2) and 1 custom PC (intel SSE3), both running Uphuck's 10.4.9 1.4i r3 (the small ISO) and one G4 Powerbook running original 10.4.10.


We're all music producers and we've been keen to have a look at Logic Pro 8. As with all the Apple Pro software it requires Apple's Pro Application Support runtime in order to run. I downloaded the 4.0.2 version from Apple and it won't install on any of the three systems (including the powerbook), in each case the problem is the same: it puts a red (!) sign over the disks during installation and says that none of the disks in the system are "eligible for this update": "Cannot install Apple Pro Application Support on this drive. This disk is not eligble for this update" or something similar (sorry not near the problem at the moment, or i'd be more precise).


I've googled and not seen anyone else have this problem, but its weird that all of us, with our vastly different systems - including the one mac - would have the exact same problem.


I've tried the following to no avail:

-re-downloaded the 4.0.2 dmg from apple on other machine in case of corruption.

-repaired drive permissions with install DVD and disk util.

-tried it on hackintosh 10.4.9 and proper mac 10.4.10


there's no help for this on any forum topic i've seen yet so I'm hoping someone here can shed some light on it for me. (i don't mind getting my hands dirty with the terminal if i get clear instructions) :P


thanks in advance guys.


Link to comment
Share on other sites

Hey guys,


Thanks! Got it to work. Had a suggestion from goro082 about using Pacifist to intall Pro App and it worked. Logic runs from any location after that.

@fb and mab238 - thanks as well! Already had it fixed at this point but if all 3 ways work then the one thing they have in common is to me seems to be a rather silly blunder on Apples part. Seems that Logic checks for Pro App support and Pro App support checks for Logic, so if you didn't have a previous Pro App of any kind (Logic 7, Aperture, Final Cut etc) and hadn't updated your Pro App support accordingly you were screwed. Pacifist seems to just bypass the check for the dependecy in both directions, whether you use it to install Logic first (which from mab's statement seems to be doable without pacifist) or to install Pro App update directly without any pro apps installed.

Link to comment
Share on other sites


  • Create New...