Jump to content

Questions Installing uphuck 10.4.9 r3


3 posts in this topic

Recommended Posts

I've got a few questions on installing this on my system. My specs are as follows:


Asus P4B266 (Intel i845d Northbridge with a ICH2 Southbridge)

P4 2.4GHz - SSE2 only

WD 500GB IDE drive (fresh and ready to be used)

SB Audigy (I know it won't work - but the Firewire can be used)

Geforce4 4400TI (Again I know no CI support... should support QE though)

Pioneer DVR-106


I tried the install a couple of times using different packages but could never get it to work.

(basically all the ones it said were good for Intel SSE2 systems):


SSE2 kernel

loginwindow from 10.4.4

IOATAFamily from 10.4.8



AGPGart 2.2

USB Patch

Startech PCI Wireless (RT2500 chipset)


Then I read somewhere to disable the parallel port in the BIOS and I did and it got farther but I don't know where it got to. I also read AGPGart 2.2 isn't needed for Intel MBs so I did an install without it.


All the time the install would go well, but on the reboot in verbose mode I would get what looked like a few errors:


Somewith with NVResman... then Titan runs and finds the 4400TI but then an error trying to bring up the display. It continues on though and gets by the loginwindow and then does something with dns and local host and it just seemed to hang here. No error messages. No kernel panics. The HD light was one though and it was reading files... However I left it here for about 20 mins and there was still nothing. I read it can take a long time to come up...


I had a few questions. Given my CPU which is the best kernel to use? SSE2 only or one of the universals?


Do I need to use the patch about using the IOATAFamily from 10.4.8 with my MB?


Do I need to use the loginwindow patch?


Lastly whats the USB patch for? Do I need it...


Given all of this, can I go back and install these extra patches after if I need them?


Thanks for your help.

Link to comment
Share on other sites


I have your same CPU, but my motherboard is one Asus P4B533 with the same 845 chip, but your mistake are the versione of IOATA, you must to use the 10.4.9, than you find it in uphuck 10.4.9r, the version with Rosetta.

I always have used that version (the r), but with the last version, (the r3), that patch don't exist (the IOATA), and you have used the old 10.4.8 version.

Maybe your problem is that, find the 10.4.9r and after you have installed the r3 version with all your necessary patch but without IOATA, you restart the computer and put in your drive the r version, and install ONLY I repeat ONLY the IOATAFamily without any other patch...

Try this, I have fix the mistake of the r3 version..


Best Regards at all.

Link to comment
Share on other sites

Alright the problem turned out to be an issue with the VGA drivers, not the IOATAFamily.kext


I had tried both Titan, Natit 0.1 and 0.2.


Both would detect my card as a TI4400 but then both would fail to load the display.


I had read in earlier threads that there was a way to hack the Info.pblist to edit the device ids directly to get it working, so I tried that but now that I look at it I used the wrong ID so it default to VESA which allowed me to boot.


For whatever reason it doesn't look like the TI4400 (and all NV25 cards) will work. You'll get a hung loginwindow.app... Funny because people did post success with the TI4200-8X AGP cards which is the NV28 and essentially the same chip (different device ID though)...


So for now, I am at least in as I am posting this message from Safari! Just have to scour ebay or the local buy/sell for a cheap 6600GT AGP (or an ATI equivalent) to throw in this and I should have a perfectly serviceable OSX box, oh and a cheap USB audio device...

Link to comment
Share on other sites


  • Create New...